Bug 539302

Summary: [abrt] crash detected in preupgrade-1.1.2-1.fc10
Product: [Fedora] Fedora Reporter: Michael Sinchenko <sinchenko>
Component: preupgradeAssignee: Richard Hughes <richard>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 12CC: jason.vas.dias, wwoods
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard: abrt_hash:5b85304b
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-12-03 22:08:17 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
File: backtrace none

Description Michael Sinchenko 2009-11-19 15:23:39 EST
abrt detected a crash.

Attached file: backtrace
cmdline: /usr/bin/python /usr/share/preupgrade/preupgrade-gtk.py 
component: preupgrade
executable: /usr/share/preupgrade/preupgrade-gtk.py
kernel: 2.6.31.5-127.fc12.i686
package: preupgrade-1.1.2-1.fc10
uuid: 5b85304b
Comment 1 Michael Sinchenko 2009-11-19 15:23:44 EST
Created attachment 372331 [details]
File: backtrace
Comment 2 Jason Vas Dias 2009-12-29 20:49:06 EST
Don't know if same cause, but I also get a Traceback with an
"Invalid cross-device link"
error when upgrading from Fedora 10 x86_64 (updated to latest
updates as of 2009-12-20), even though I have ensured there
is enough free disk space in /var/cache/yum/preupgrade* .

If cross-device links are not invalid to file-systems,
why are they invalid to preupgrade ?

$ %1
preupgrade	(wd: /var/cache/yum)
Available disk space for /var/cache/yum/preupgrade: 1.4GB
Upgrade requires 500.0MB
Available disk space for /usr: 554.7MB
Kernel requires 26.0MB
Available disk space for /boot: 554.7MB
Generating metadata for preupgrade repo
Traceback (most recent call last):
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 773, in <module>
    widgets = PreUpgradeGtk()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 376, in __init__
    self._do_main()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 259, in _do_main
    self.main_preupgrade()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 556, in main_preupgrade
    callback=MDGenCallback(pbar=self.progress))
  File "/usr/lib/python2.5/site-packages/preupgrade/__init__.py", line 658, in generate_repo
    self.gather_downloaded_packages(dir)
  File "/usr/lib/python2.5/site-packages/preupgrade/__init__.py", line 672, in gather_downloaded_packages
    os.link(os.path.join(fullpkgdir,p),newfile)
OSError: [Errno 18] Invalid cross-device link

If I can't find any "cross-device link" preupgrade bugs I think one should
be opened - I'll open one with suggested patch over the next day unless
otherwise advised.

thanks, Jason
Comment 3 Jason Vas Dias 2009-12-29 23:06:34 EST
anyway, this patch seems to work:

$ diff -u /usr/share/preupgrade/preupgrade-gtk.py~ /usr/share/preupgrade/preupgrade-gtk.py
--- /usr/share/preupgrade/preupgrade-gtk.py~	2009-12-30 04:06:06.000000000 +0000
+++ /usr/share/preupgrade/preupgrade-gtk.py	2009-12-30 02:45:35.000000000 +0000
@@ -251,12 +251,19 @@
                         break
 
     def _do_main(self):
-        self.release_name = self.release_selection.get_active_text()
-        if self.release_name is None:
-           return
-        if not self.running:
-           self.running = True
-           self.main_preupgrade()
+        try:
+            self.release_name = self.release_selection.get_active_text()
+            if self.release_name is None:
+                return
+            if not self.running:
+                self.running = True
+                self.main_preupgrade()
+        except ( e ) :
+            r = continueQuitDialog(self.ui.assistant,"It happened : %s Try to continue ?" % e)
+            if r == gtk.RESPONSE_NO:
+                self.quit(exitcode=1)
+            else:
+
Comment 4 Jason Vas Dias 2009-12-29 23:12:49 EST
oops - missed last line:

+                _do_main(self)
Comment 5 Jason Vas Dias 2009-12-29 23:19:48 EST
Complete patch:

$ diff -u preupgrade-gtk.py~~ preupgrade-gtk.py
--- preupgrade-gtk.py~~	2009-12-30 04:19:06.000000000 +0000
+++ preupgrade-gtk.py	2009-12-30 04:15:31.000000000 +0000
@@ -251,12 +251,19 @@
                         break
 
     def _do_main(self):
-        self.release_name = self.release_selection.get_active_text()
-        if self.release_name is None:
-            return
-        if not self.running:
-            self.running = True
-            self.main_preupgrade()
+        try:
+            self.release_name = self.release_selection.get_active_text()
+            if self.release_name is None:
+                return
+            if not self.running:
+                self.running = True
+                self.main_preupgrade()
+        except ( Exception, e ) :
+            r = continueQuitDialog(self.ui.assistant,"It happened : %s Try to continue ?" % e)
+            if r == gtk.RESPONSE_NO:
+                self.quit(exitcode=1)
+            else:
+                _do_main(self)
Comment 6 Jason Vas Dias 2009-12-29 23:52:59 EST
+        except  Exception, e  :
:-(
Comment 7 Jason Vas Dias 2009-12-29 23:54:15 EST
tcldom-gui-3.1-12.fc9.x86_64 from installed has depsolving problems
  --> Missing Dependency: tcldom = 3.1-12.fc9 is needed by package tcldom-gui-3.1-12.fc9.x86_64 (installed)
dejavu-sans-mono-fonts-2.30-2.fc12.noarch from preupgrade-fedora has depsolving problems
  --> dejavu-sans-mono-fonts conflicts with dejavu-fonts-experimental
dejavu-serif-fonts-2.30-2.fc12.noarch from preupgrade-fedora has depsolving problems
  --> dejavu-serif-fonts conflicts with dejavu-fonts-experimental
childsplay-1.4-2.fc10.noarch from installed has depsolving problems
  --> Missing Dependency: python(abi) = 2.5 is needed by package childsplay-1.4-2.fc10.noarch (installed)
dejavu-sans-fonts-2.30-2.fc12.noarch from preupgrade-fedora has depsolving problems
  --> dejavu-sans-fonts conflicts with dejavu-fonts-experimental
dejavu-sans-fonts-2.30-2.fc12.noarch from preupgrade-fedora has depsolving problems
  --> dejavu-sans-fonts conflicts with dejavu-fonts
dejavu-serif-fonts-2.30-2.fc12.noarch from preupgrade-fedora has depsolving problems
  --> dejavu-serif-fonts conflicts with dejavu-fonts
dejavu-sans-mono-fonts-2.30-2.fc12.noarch from preupgrade-fedora has depsolving problems
  --> dejavu-sans-mono-fonts conflicts with dejavu-fonts
python-json-3.4-4.fc10.noarch from installed has depsolving problems
  --> Missing Dependency: python(abi) = 2.5 is needed by package python-json-3.4-4.fc10.noarch (installed)
totem-tracker-2.24.3-3.fc10.x86_64 from installed has depsolving problems
  --> Missing Dependency: totem = 2.24.3-3.fc10 is needed by package totem-tracker-2.24.3-3.fc10.x86_64 (installed)
tcldom-gui-3.1-12.fc9.x86_64 from installed has depsolving problems
  --> Missing Dependency: tcldom = 3.1-12.fc9 is needed by package tcldom-gui-3.1-12.fc9.x86_64 (installed)
dejavu-sans-mono-fonts-2.30-2.fc12.noarch from preupgrade-fedora has depsolving problems
  --> dejavu-sans-mono-fonts conflicts with dejavu-fonts-experimental
dejavu-serif-fonts-2.30-2.fc12.noarch from preupgrade-fedora has depsolving problems
  --> dejavu-serif-fonts conflicts with dejavu-fonts-experimental
childsplay-1.4-2.fc10.noarch from installed has depsolving problems
  --> Missing Dependency: python(abi) = 2.5 is needed by package childsplay-1.4-2.fc10.noarch (installed)
dejavu-sans-fonts-2.30-2.fc12.noarch from preupgrade-fedora has depsolving problems
  --> dejavu-sans-fonts conflicts with dejavu-fonts-experimental
dejavu-sans-fonts-2.30-2.fc12.noarch from preupgrade-fedora has depsolving problems
  --> dejavu-sans-fonts conflicts with dejavu-fonts
dejavu-serif-fonts-2.30-2.fc12.noarch from preupgrade-fedora has depsolving problems
  --> dejavu-serif-fonts conflicts with dejavu-fonts
dejavu-sans-mono-fonts-2.30-2.fc12.noarch from preupgrade-fedora has depsolving problems
  --> dejavu-sans-mono-fonts conflicts with dejavu-fonts
python-json-3.4-4.fc10.noarch from installed has depsolving problems
  --> Missing Dependency: python(abi) = 2.5 is needed by package python-json-3.4-4.fc10.noarch (installed)
totem-tracker-2.24.3-3.fc10.x86_64 from installed has depsolving problems
  --> Missing Dependency: totem = 2.24.3-3.fc10 is needed by package totem-tracker-2.24.3-3.fc10.x86_64 (installed)

::--((
Comment 8 Jason Vas Dias 2009-12-29 23:57:59 EST
+ self->_do_main()
Comment 9 Jason Vas Dias 2009-12-30 01:40:13 EST
of course, problem continues after 
 $ rpm -e --nodeps totem-tracker python-json dejavu-fonts\
   dejavu-fonts-experimental tcldom-gui

See Bug #551338
Comment 10 Fedora Admin XMLRPC Client 2010-04-16 10:35:02 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 11 Bug Zapper 2010-11-04 02:00:24 EDT
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 Bug Zapper 2010-12-03 22:08:17 EST
Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.