Bug 539765

Summary: Attempts to connect to 255.255.255.255
Product: [Fedora] Fedora Reporter: Matt McCutchen <matt>
Component: cvspsAssignee: Ville Skyttä <ville.skytta>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 11CC: florian.laroche, michel, ville.skytta
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-03-15 05:15:21 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Matt McCutchen 2009-11-21 00:42:18 UTC
Description of problem:
On my 64-bit system, cvsps makes a bogus attempt to connect to 255.255.255.255 because it fails to determine whether the given hostname could be parsed as a dotted-decimal IP address.

Version-Release number of selected component (if applicable):
cvsps-2.2-0.4.b1.fc11.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. rm -f ~/.cvsps/":pserver:anonymous@cvs.fedoraproject.org:#cvs#pkgs#rpms#cvsps"
2. strace -e trace=connect cvsps --cvs-direct --root :pserver:anonymous@cvs.fedoraproject.org:/cvs/pkgs rpms/cvsps
  
Actual results:
connect(3, {sa_family=AF_INET, sin_port=htons(2401), sin_addr=inet_addr("255.255.255.255")}, 16) = -1 ENETUNREACH (Network is unreachable)
connect error: Network is unreachable
--- SIGCHLD (Child exited) @ 0 (0) ---
WARNING: malformed CVS version: no data
WARNING: malformed CVS version str: (UNKNOWN CLIENT)
WARNING: Your CVS client version:
[(UNKNOWN CLIENT)]
and/or server version:
[(UNKNOWN SERVER)]
are too old to properly support the rlog command. 
This command was introduced in 1.11.1.  Cvsps
will use log instead, but PatchSet numbering
may become unstable due to pruned empty
directories.

cvs log: No CVSROOT specified!  Please use the `-d' option
cvs [log aborted]: or set the CVSROOT environment variable.
--- SIGCHLD (Child exited) @ 0 (0) ---

Expected results:
Successful connection and output.

Additional info:
The following patch appears to solve this problem:
http://repo.or.cz/w/cvsps-yd.git/commitdiff/c498733b4283b3987bdca6949a5e304244b64cfc

Comment 1 Ville Skyttä 2009-12-23 15:10:15 UTC
Thanks for the detailed report and sorry about the delay.  Building with -DLINUX circumvents the issue and is a patch-free approach, so I opted to use that.  Updates will follow shortly.

Comment 2 Fedora Update System 2009-12-23 15:28:22 UTC
cvsps-2.2-0.5.b1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/cvsps-2.2-0.5.b1.fc12

Comment 3 Fedora Update System 2009-12-23 15:29:20 UTC
cvsps-2.2-0.5.b1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/cvsps-2.2-0.5.b1.fc11

Comment 4 Fedora Update System 2009-12-23 15:34:02 UTC
cvsps-2.1-7.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/cvsps-2.1-7.el5

Comment 5 Fedora Update System 2009-12-24 20:35:38 UTC
cvsps-2.2-0.5.b1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update cvsps'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-13603

Comment 6 Matt McCutchen 2010-03-15 05:15:21 UTC
All the updates linked above were pushed to stable on 2010-01-12.  The update system should have closed this bug.

Comment 7 Florian La Roche 2010-08-08 07:03:58 UTC
This patch is not included in rhel6.

regards,

Florian La Roche

Comment 8 Ville Skyttä 2010-08-08 16:14:09 UTC
I suggest contacting the RHEL6 cvsps maintainer, and while at it, checking whether the RHEL6 one will properly update the EPEL5 one.