This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 539886

Summary: preupgrade of F11 to F12 has changed bootable flag from 1sth to 3thd partition
Product: [Fedora] Fedora Reporter: Eddie Lania <eddie>
Component: anacondaAssignee: Hans de Goede <hdegoede>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: vanmeeuwen+fedora, wwoods
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-11-28 14:55:47 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Eddie Lania 2009-11-21 08:37:54 EST
Description of problem: preupgrade of F11 to F12 has overwritten my boot sector. now I am unable to boot my windows partitions anymore! The previous GRUB boot sector belonged to the start of the partition on which the Fedora Linux has been installed leaving the original boot manager from Windows Vista on the boot sector of the primary first drive/partition.



Version-Release number of selected component (if applicable):
Currunt version now is preupgrade-1.1.3-1.fc12.noarch, however, this is the version from F12 that has replace the preupgrade version from F11 so I am unable to report which version that was in the first place.

How reproducible: Always when preupgrade on a system with grub installed on the linux partition instead of the primary boot sector on the first boot drive/partition.


Steps to Reproduce:
1.
2.
3.
  
Actual results: System now happily boots only to Linux OS and I am unable to boot my windows partitions anymore


Expected results: Grub should have stayed on the boot sector of the linux partition (/dev/sda3) instead.


Additional info:

I am very disappointed about this and hope somebody is able to tell me shortly which steps I have to follow to restore my previous boot manager (nt) on the primary boot sector of the system so that my other OS's are available again.
Comment 1 Eddie Lania 2009-11-26 12:15:06 EST
From the Grub bootmanager, I am now able to boot the bootmgr from Vista. From the bootmgr of Vista I also am able to boot the Fedora partition (like it was before the preupgrade) back again.

Should I perform a "bootrec /FixBoot" from within Vista? So that my previous boot manager from Vista will be enabled again?

If so, will future updates to grub overwrite the primary bootsector again?
Comment 2 Eddie Lania 2009-11-26 12:17:00 EST
Here is my grub config:

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You do not have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /, eg.
#          root (hd0,2)
#          kernel /boot/vmlinuz-version ro root=/dev/sda3
#          initrd /boot/initrd-version.img
#boot=/dev/sda3
default=0
timeout=5
splashimage=(hd0,2)/boot/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.31.6-134.fc12.i686.PAE)
<------>root (hd0,2)
<------>kernel /boot/vmlinuz-2.6.31.6-134.fc12.i686.PAE ro root=LABEL=/ rhgb quiet SYSFONT=latarcyrheb-sun16 LANG=en_US.UTF-8 KEYTABLE=us
<------>initrd /boot/initramfs-2.6.31.6-134.fc12.i686.PAE.img
title Fedora (2.6.31.5-127.fc12.i686)
<------>root (hd0,2)
<------>kernel /boot/vmlinuz-2.6.31.5-127.fc12.i686 ro root=LABEL=/ rhgb quiet SYSFONT=latarcyrheb-sun16 LANG=en_US.UTF-8 KEYTABLE=us
<------>initrd /boot/initramfs-2.6.31.5-127.fc12.i686.img
title Fedora (2.6.31.5-127.fc12.i686.PAE)
<------>root (hd0,2)
<------>kernel /boot/vmlinuz-2.6.31.5-127.fc12.i686.PAE ro root=LABEL=/ rhgb quiet SYSFONT=latarcyrheb-sun16 LANG=en_US.UTF-8 KEYTABLE=us
<------>initrd /boot/initramfs-2.6.31.5-127.fc12.i686.PAE.img
title Fedora (2.6.30.9-96.fc11.i586)
<------>root (hd0,2)
<------>kernel /boot/vmlinuz-2.6.30.9-96.fc11.i586 ro root=LABEL=/ rhgb quiet
<------>initrd /boot/initrd-2.6.30.9-96.fc11.i586.img
title Fedora (2.6.30.9-90.fc11.i586)
<------>root (hd0,2)
<------>kernel /boot/vmlinuz-2.6.30.9-90.fc11.i586 ro root=LABEL=/ rhgb quiet
<------>initrd /boot/initrd-2.6.30.9-90.fc11.i586.img
title Other
<------>rootnoverify (hd0,0)
<------>chainloader +1
Comment 3 Hans de Goede 2009-11-27 05:10:39 EST
Eddie, let me see if I understand this correctly, after doing an upgrade from
F-11 to F-12, using pre-upgrade to download the installer and the necessary files,
your machine now no longer starts with the NT-bootloader, but instead starts with grub?

I have a hunch that this is the same issue as bug 533658, can you please run:
parted /dev/sda p

And then paste the output here ? Thanks.
Comment 4 Eddie Lania 2009-11-27 12:31:04 EST
Here is the output of "parted /dev/sda p":

Model: ATA ST3160815AS (scsi)
Disk /dev/sda: 160GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type      File system     Flags
 1      32.3kB  41.9GB  41.9GB  primary   ntfs
 2      41.9GB  83.9GB  41.9GB  primary   ntfs
 3      83.9GB  122GB   37.7GB  primary   ext3            boot
 4      122GB   160GB   38.4GB  extended
 5      122GB   123GB   1612MB  logical   linux-swap(v1)  swap
 6      123GB   160GB   36.8GB  logical   fat32

So I need to toggle the bootable flag back to number 1?
Comment 5 Hans de Goede 2009-11-27 12:36:11 EST
Yes, that will probably fix things, can you give that a try please ?
Comment 6 Eddie Lania 2009-11-27 12:57:03 EST
Ok, I set the bootable flag to partition Nr. 1. and it is solved now.

Regards,

Eddie.
Comment 7 Hans de Goede 2009-11-28 14:55:47 EST
Eddie,

Thanks for testing. This means that this bug is a duplicate of bug
533658, which I'm happy to report has been fixed for F-13 (see bug 533658 for details).

Regards,

Hans

*** This bug has been marked as a duplicate of bug 533658 ***