Due to a recent update on Javascript code a full page refresh on your browser might be needed.

Bug 540687

Summary: munin-node package update overrides some configuration changes
Product: [Fedora] Fedora EPEL Reporter: Mike Loseke <mike>
Component: muninAssignee: Kevin Fenzi <kevin>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: el5CC: kevin
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 1.4.3-2.fc11 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-02-11 14:34:32 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Mike Loseke 2009-11-23 23:07:52 UTC
Steps to Reproduce:
1. Install munin and munin-node.
2. Make changes to the system, like removing a symlink in /etc/munin/plugins/.
3. Update the munin packages, the symlink will be re-created.
  
Actual results:
A modified munin configuration is partially reset to that of a new install on a package update.

Expected results:
A modified system should retain the existing configuration changes after an update, in this case leaving removed plugins removed.

Additional info:
The munin package doesn't have the functionality to exclude package-provided plugins in any other method aside from making sure that they don't appear in /etc/munin/plugins/.  The %post script in the spec file always runs /usr/sbin/munin-node-configure, but this should only be run after an install, not an update.  For instance, maybe replacing the munin-node-configure command with the following:

    if [ "$1" = "1" ]; then
        /usr/sbin/munin-node-configure --shell 2> /dev/null | sh >& /dev/null || :
    fi

Comment 1 Kevin Fenzi 2009-11-27 03:31:31 UTC
Yeah, the only downside to that is that on new version bumps it won't get you new spiffy plugins that would otherwise be autodetected. 

I guess possibly the way to do things would be use this scriptlet for minor changes and for major version changes to the total reconfig that it currently does.

Comment 2 Kevin Fenzi 2010-01-17 20:13:53 UTC
Thinking about it more, that idea isn't going to work either, as we can't know what version people are upgrading from easily. ;( 

So, that leaves us with: 

A. We could keep running munin-node-configure on updates, and local modifications will be lost. 
B. We could only run it on installs, but then you miss out on new plugins. 

I guess B is probibly the better course, since we don't want to loose user config data. ;( 

I have just checked in such a change in rawhide. 
Would like to let it cook for a few days there, then update 12/11/el5/el4.

Comment 3 Fedora Update System 2010-01-22 16:40:14 UTC
munin-1.4.3-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/munin-1.4.3-2.fc12

Comment 4 Fedora Update System 2010-01-22 16:41:12 UTC
munin-1.4.3-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/munin-1.4.3-2.fc11

Comment 5 Fedora Update System 2010-01-26 01:03:37 UTC
munin-1.4.3-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update munin'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2010-1058

Comment 6 Fedora Update System 2010-01-26 01:03:46 UTC
munin-1.4.3-2.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update munin'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-1062

Comment 7 Fedora Update System 2010-02-11 14:34:27 UTC
munin-1.4.3-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2010-02-11 14:57:05 UTC
munin-1.4.3-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.