This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 541257

Summary: FN5 & FN6 keys fail to control brightness on sony vaio VGN-FW51Z/H laptop.
Product: [Fedora] Fedora Reporter: Mark Lees <bugzilla>
Component: acpidAssignee: Jiri Skala <jskala>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 12CC: aglotov, eric.donkersloot, jskala
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-02-22 04:17:48 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Mark Lees 2009-11-25 07:10:45 EST
Description of problem:

On my Sony VGN-FW51ZF/H laptopn then FN5 + FN6 Keys do not allow brightness to be controlled.


Version-Release number of selected component (if applicable):

How reproducible: 

Easily reproducible.

Steps to Reproduce:
1.  Press the FN5 key
2.
3.
  
Actual results:
Brightness of screen does not change

Expected results:
Brightness of screen should dim.

Additional info:
I think I've narrowed it down to either the  sony-laptop or acpi modules.

When pressing other keys, like the "AV Mode" key, I get a message in /var/log/messages which states.

Nov 25 12:08:56 localhost kernel: sony-laptop: Unknown event: 0x100 0xa1
Nov 25 12:08:56 localhost kernel: sony-laptop: Unknown event: 0x100 0x21

However, pressing the FN5 + FN6 keys does not produce these messages so I'm assuming that they are being trapped but not working correctly.

Thx
Mark.
Comment 1 Eric Donkersloot 2009-12-01 09:52:47 EST
Please try this workaround: reboot your machine with the 'nomodeset' kernel parameter. This might be a duplicate of bug 519105 ?
Comment 2 Steven M. Parrish 2009-12-06 15:03:27 EST
Reassigned to correct component

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Mark Lees 2009-12-06 15:35:09 EST
I tried the nomodeset option and it had no effect. The FN5/6 keys still do not affect the brightness of the display.
Comment 4 Jiri Skala 2010-02-22 04:17:48 EST
(In reply to comment #1)
> Please try this workaround: reboot your machine with the 'nomodeset' kernel
> parameter. This might be a duplicate of bug 519105 ?    

The question was not answered but I went through the bug #519105 I'm convinced this bug duplicates #519105. Therefore I close this as a duplicity.

*** This bug has been marked as a duplicate of bug 519105 ***
Comment 5 Mark Lees 2010-02-22 13:47:22 EST
Hi Jiri,

I'm not sure what you mean by "This question was not answered" as if you'd taken just a few seconds you would have spotted my reponse which, to save you having to waste your obviously valueable time, I have reposted here.

"I tried the nomodeset option and it had no effect. The FN5/6 keys still do not
affect the brightness of the display."..

Regards
Mark.
Comment 6 Jiri Skala 2010-02-23 02:14:46 EST
Hi Mark,
I'm sorry I didn't explain it with accuracy. You really reacted on the comment #1 (I' spent more time than seconds with this issue :-)). I've mentioned the second part about duplicity to #519105 that is key point.

Regards

Jiri