Bug 541686

Summary: Remove erroneous modeswitch rules
Product: [Fedora] Fedora Reporter: antonio montagnani <antonio.montagnani>
Component: udevAssignee: Harald Hoyer <harald>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 12CC: dcbw, harald, jonathan, mail
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: Huawei 1692 is not started with default configuration
Fixed In Version: 145-15.fc12 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-02-11 01:51:52 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Output of usb_modeswitch -W in F12
none
usb_modeswitch -W in F11 where it works none

Description antonio montagnani 2009-11-26 13:14:54 EST
Description of problem:
When I issue usb_modeswitch the card is not recognized as a 3G card if I use the standard configuration file with these lines:

# Huawei E1692
#
# Contributor: Roberto Riggio

DefaultVendor=  0x12d1
DefaultProduct= 0x1446

# choose one of these:
;DetachStorageOnly=1
HuaweiMode=1

Version-Release number of selected component (if applicable):
usb_modeswitch-1.0.5-1.fc12.i686

How reproducible:
always

Steps to Reproduce:
1.connect card
2.I get a Huawei SD storage and UnitCD:AlicemobileHW icons in Computer
3.usb_modeswitch

Looking for default devices ...
 Found default devices (1)
Accessing device 006 on bus 002 ...
Using endpoints 0x01 (out) and 0x81 (in)
Inquiring device details; driver will be detached ...
Looking for active driver ...
 OK, driver found ("usb-storage")
 OK, driver "usb-storage" detached

Received inquiry data (detailed identification)
-------------------------
  Vendor String: HUAWEI  
   Model String: Mass Storage    
Revision String: 2.31
-------------------------

Device description data (identification)
-------------------------
Manufacturer: HUAWEI Technology
     Product: HUAWEI Mobile
  Serial No.: not provided
-------------------------
Sending Huawei control message ...
 OK, Huawei control message sent
-> Run lsusb to note any changes. Bye.

5) after that UnitCD:AlicemobileHW is deleted from computer 
6) from lsusb I get

Bus 002 Device 006: ID 12d1:1446 Huawei Technologies Co., Ltd. 
Bus 002 Device 004: ID 064e:a101 Suyin Corp. Acer CrystalEye Webcam
Bus 002 Device 003: ID 0471:200d Philips 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 002: ID 045e:00a4 Microsoft Corp.
  
Actual results:
I assume that 
Bus 002 Device 006: ID 12d1:1446 Huawei Technologies Co., Ltd.
is still a mass storage and not a 3g card
anyway I don't get any 3G available connection

Expected results:
I should have an available connection as when I used these lines :

Huawei E1692

DefaultVendor=  0x12d1
DefaultProduct= 0x1446

TargetVendor=   0x12d1
TargetProduct=  0x140c

MessageEndpoint=0x01
MessageContent="55534243000000000000000000000011060000000000000000000000000000"

CheckSuccess=5

Additional info:
Comment 1 antonio montagnani 2009-12-13 15:45:31 EST
 and after latest updates (but still) usb_modeswitch-1.0.5-1.fc12.i686

usb_modeswitch

Looking for default devices ...
 Found default devices (1)
Accessing device 002 on bus 001 ...
Using endpoints 0x01 (out) and 0x81 (in)
Inquiring device details; driver will be detached ...
Looking for active driver ...
 No driver found. Either detached before or never attached

When I use 
# Huawei E1692
#
# Contributor: Roberto Riggio

DefaultVendor=  0x12d1
DefaultProduct= 0x1446

# choose one of these:
;DetachStorageOnly=1
HuaweiMode=1

and in the first step I don't see the SD storage as in comment #1
_________________________________________________________________________

If I revert to :

# Huawei E1692

DefaultVendor=  0x12d1
DefaultProduct= 0x1446

TargetVendor=   0x12d1
TargetProduct=  0x140c

MessageEndpoint=0x01
MessageContent="55534243000000000000000000000011060000000000000000000000000000"

CheckSuccess=5

I get:

Looking for target devices ...
 No devices in target mode or class found
Looking for default devices ...
 Found default devices (1)
Accessing device 005 on bus 002 ...
Using endpoints 0x01 (out) and 0x81 (in)
Inquiring device details; driver will be detached ...
Looking for active driver ...
 No driver found. Either detached before or never attached
_____________________________________________________________

I am using in both cases 2.6.31.6-166.fc12.i686.PAE

Does this means that I will not be able to surf during Xmas???
Comment 2 antonio montagnani 2009-12-15 10:34:28 EST
I fear that the component to be blamesd is kernel.... :-(
Comment 3 antonio montagnani 2009-12-18 06:34:26 EST
I note that in F12 there is no file for usb_modeswitch.rules in /etc/udev/rules.d that is present in F11....

Is this the issue???
Comment 4 antonio montagnani 2009-12-28 18:01:19 EST
Created attachment 380699 [details]
Output of usb_modeswitch -W in F12

I issued usb_modeswitch with same file as in F11 where dongle is working great
Comment 5 antonio montagnani 2009-12-28 18:03:03 EST
Created attachment 380700 [details]
usb_modeswitch -W in F11 where it works

in F11 same dongle with same usb_modeswitch.conf file is working great
Comment 6 antonio montagnani 2010-01-15 04:06:02 EST
I see that a new release (1.0.7) is available on usb_modeswitch website that claims that solves the problem with new udev.

Shall it fix my problem???
Comment 7 antonio montagnani 2010-01-17 09:15:46 EST
solved tnx to the help of Josua Dietze at USB_ModeSwitch website.
I disabled this line in /lib/udev/rules.d/61-option-modem-modeswitch.rules
#ATTRS{idVendor}=="12d1", ATTRS{idProduct}=="1446",
RUN+="modem-modeswitch -v 0x%s{idVendor} -p 0x%s{idProduct} -t
option-zerocd"
and now it works even with no usb_modeswitch
Comment 8 Dan Williams 2010-01-20 21:11:17 EST
(In reply to comment #7)
> solved tnx to the help of Josua Dietze at USB_ModeSwitch website.
> I disabled this line in /lib/udev/rules.d/61-option-modem-modeswitch.rules
> #ATTRS{idVendor}=="12d1", ATTRS{idProduct}=="1446",
> RUN+="modem-modeswitch -v 0x%s{idVendor} -p 0x%s{idProduct} -t
> option-zerocd"
> and now it works even with no usb_modeswitch    

That line is already removed in udev upstream and should make it's way to F12 at some point... moving bug to udev to track that issue then.
Comment 9 Fedora Update System 2010-01-26 07:57:25 EST
udev-145-15.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/udev-145-15.fc12
Comment 10 Fedora Update System 2010-01-27 19:55:28 EST
udev-145-15.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update udev'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-1138
Comment 11 antonio montagnani 2010-02-11 01:51:52 EST
It seems to be solved.
Comment 12 Fedora Update System 2010-02-11 23:45:49 EST
udev-145-15.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.