Bug 542239

Summary: preupgrade-cli fails at every moment with a distribution set to spanish
Product: [Fedora] Fedora Reporter: Maximiliano Castanon <maximi89>
Component: preupgradeAssignee: Seth Vidal <skvidal>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 13CC: kanelxake, wwoods
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-06-27 10:36:53 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Maximiliano Castanon 2009-11-28 18:23:45 EST
Description of problem:
preupgrade in a distribution set to spanish fails at every moment and exit with error of unicode.

Version-Release number of selected component (if applicable):
[maximi89@gateway ~]$ rpm -q preupgrade
preupgrade-1.1.3-1.fc11.noarch


How reproducible:
always opening the preupgrade-cli

Steps to Reproduce:
1.open preupgrade-cli on a spanish distribution of fedora and this going fail after ask you anything
2.
3.
  
Actual results:
fails

Expected results:
to work

Additional info:


open 
preupgrade-cli 

and you will see af the end this:

zlib-devel.i686                          1.2.3-23.fc12          preupgrade-fedora
zvbi.i686                                0.2.33-4.fc12          preupgrade-fedora
Total download size: 1.2GB
Download packages? 
Traceback (most recent call last):
  File "/usr/share/preupgrade/preupgrade-cli.py", line 312, in <module>
    pu.main(myrelease)
  File "/usr/share/preupgrade/preupgrade-cli.py", line 250, in main
    if not self.userconfirm():
  File "/usr/share/yum-cli/output.py", line 629, in userconfirm
    choice = raw_input(_('Is this ok [y/N]: '))
UnicodeEncodeError: 'ascii' codec can't encode character u'\xe1' in position 3: ordinal not in range(128)
Comment 1 Bug Zapper 2010-03-15 09:23:11 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Peter Hjalmarsson 2010-10-22 11:18:52 EDT
This seems to be the same as I have in fedora-13:

# preupgrade-cli "Fedora 14 (Laughlin)"
<snip>

zenity.x86_64                            2.32.0-1.fc14          preupgrade-main 
zip.x86_64                               3.0-2.fc14             preupgrade-main 
zlib.x86_64                              1.2.5-2.fc14           preupgrade-main 
Totalt storlek att hämta: 330.0MB
Hämta paket? 
Traceback (most recent call last):
  File "/usr/share/preupgrade/preupgrade-cli.py", line 327, in <module>
    pu.main(release)
  File "/usr/share/preupgrade/preupgrade-cli.py", line 265, in main
    if not self.userconfirm():
  File "/usr/share/yum-cli/output.py", line 687, in userconfirm
    choice = raw_input(_('Is this ok [y/N]: '))
UnicodeEncodeError: 'ascii' codec can't encode character u'\xc4' in position 0: ordinal not in range(128)
#



However this works fine:
# LANG="C" preupgrade-cli "Fedora 14 (Laughlin)"
Comment 3 Bug Zapper 2011-06-02 13:16:30 EDT
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Bug Zapper 2011-06-27 10:36:53 EDT
Fedora 13 changed to end-of-life (EOL) status on 2011-06-25. Fedora 13 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.