Bug 54287

Summary: Missing documentation for raidhot*
Product: [Retired] Red Hat Linux Reporter: Alexandre Oliva <aoliva>
Component: raidtoolsAssignee: Arjan van de Ven <arjanv>
Status: CLOSED WONTFIX QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 9CC: chris.ricker, tao
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-10-05 12:26:56 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Alexandre Oliva 2001-10-03 10:46:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20010913

Description of problem:
There are no man-pages for raidhotadd, raidhotremove nor
raidhotgenerateerror, and the --help output is confusing.  It's not clear
that the `*' is supposed to be a list of disk device names, not necessarily
md ones.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.raidhotadd --help
2.man raidhotadd
3.man -k raidhotadd
4.pull hair out
	

Actual Results:  usage: raidhotadd [--all] [--configfile] [--help]
[--version] [-achv] </dev/md?>*
No manual entry for raidhotadd
raidhotadd: nothing appropriate



Expected Results:  usage: raidhotadd [--all] [--configfile filename]
[--help] [[-version] [-achv] </dev/md?> </dev/[mhs]d*> [...]
Spiffy man-page explaining how/why/when to use these commands.

Additional info:
Comment 1 Chris Ricker 2002-01-15 12:49:34 EST
I definitely second this bug report.  I got bit this morning by the confusing
output from raidhot* --help, and since there's no other documentation for the
commands....
Comment 2 Chris Ricker 2002-08-30 09:43:09 EDT
Still true with null....
Comment 3 Chris Ricker 2002-10-04 18:11:49 EDT
still true with RHL 8.0
Comment 4 Patrick C. F. Ernzer 2003-02-27 07:36:58 EST
still true with 8.0.94
Comment 5 Alexandre Oliva 2003-05-11 20:08:09 EDT
and 9...
Comment 6 Alexandre Oliva 2004-10-05 12:26:56 EDT
And now raidtools are gone (won't be in FC3).