Bug 543611

Summary: preupgrade crashes on resume
Product: [Fedora] Fedora Reporter: Jeremy Huddleston <jeremyhu>
Component: preupgradeAssignee: Seth Vidal <skvidal>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 11CC: wwoods
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-12-02 13:14:17 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Jeremy Huddleston 2009-12-02 13:07:27 EST
Description of problem:

preupgrade crashes when attempting to resume an upgrade from fc11 to fc12

Version-Release number of selected component (if applicable):
1.1.3-1.fc11.noarch

How reproducible:
Uncertain


Steps to Reproduce:
1. Install F11
2. Update F11 to latest versions
3. Run 'preupgrade'
4. Quit preupgrade
5. Restart preupgrade
6. Answer, "Yes, resume"
  
Actual results:

preupgrade crashes:

Traceback (most recent call last):
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 773, in <module>
    widgets = PreUpgradeGtk()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 376, in __init__
    self._do_main()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 259, in _do_main
    self.main_preupgrade()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 436, in main_preupgrade
    download_progressbar=self.dnlProgress)
  File "/usr/lib/python2.6/site-packages/preupgrade/__init__.py", line 130, in setup
    self.complete_repo_setup()
  File "/usr/lib/python2.6/site-packages/preupgrade/__init__.py", line 328, in complete_repo_setup
    repo._grabfunc.opts.user_agent = __user_agent__
AttributeError: 'NoneType' object has no attribute 'opts'


Expected results:

Continue the upgrade


Additional info:
Comment 1 seth vidal 2009-12-02 13:14:17 EST

*** This bug has been marked as a duplicate of bug 538118 ***