Bug 543644
| Summary: | IP6 tables not loaded when booting from kernel 2.6.31.6-145.f12.x86_64 | ||||||||
|---|---|---|---|---|---|---|---|---|---|
| Product: | [Fedora] Fedora | Reporter: | Simon Lewis <simon.lewis> | ||||||
| Component: | kernel | Assignee: | Kernel Maintainer List <kernel-maint> | ||||||
| Status: | CLOSED DUPLICATE | QA Contact: | Fedora Extras Quality Assurance <extras-qa> | ||||||
| Severity: | urgent | Docs Contact: | |||||||
| Priority: | low | ||||||||
| Version: | 12 | CC: | dougsland, gansalmon, itamar, kernel-maint, nando, simon.lewis, zaitcev | ||||||
| Target Milestone: | --- | ||||||||
| Target Release: | --- | ||||||||
| Hardware: | x86_64 | ||||||||
| OS: | Linux | ||||||||
| Whiteboard: | |||||||||
| Fixed In Version: | Doc Type: | Bug Fix | |||||||
| Doc Text: | Story Points: | --- | |||||||
| Clone Of: | Environment: | ||||||||
| Last Closed: | 2009-12-05 09:03:08 UTC | Type: | --- | ||||||
| Regression: | --- | Mount Type: | --- | ||||||
| Documentation: | --- | CRM: | |||||||
| Verified Versions: | Category: | --- | |||||||
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |||||||
| Cloudforms Team: | --- | Target Upstream Version: | |||||||
| Embargoed: | |||||||||
| Attachments: |
|
||||||||
Net do not work on ASUS P5W64 Pro mobo with skge/sky2 net driver with 2 GB RAM and NM disabled. For me problems with iptables are the result of no network initialized on boot. Errors of no eth0/eth1 device known during boot. Net with kernel 2.6.31.5-127.fc12.x86_64 works. Is it releated to Bug 447489 - [x86-64] No network with 4GB RAM support? BTW. The same kernel-2.6.31.6-145.f12.i686 update on 32-bit IBM Thinkpad T41 effectively disables graphical startup. Only asci one works. Sorry, but do not have immidiate access to the first mentioned machine. If any logs are required I can send them later. :-) Thanks to a tip from Fernando Lopez-Lezcano: I have been able to determine that kernel installation did not create the "modules.dep", etc.. in the folder "/lib/modules/2.6.31.6-145.fc12.x86_64" Please advise how to rectify this error? Simon It's very easy to re-run depmod -ae, but the issue is, it should be run automatically from %postin. If that didn't happen, something malfunctioned. For reference here is the post install script for the 2.6.31.6-145.fc12.x86_64 kernel: [root@hp550-01 simon]# rpm -q --scripts kernel postinstall scriptlet (using /bin/sh): if [ `uname -i` == "x86_64" -o `uname -i` == "i386" ] && [ -f /etc/sysconfig/kernel ]; then /bin/sed -r -i -e 's/^DEFAULTKERNEL=(kernel-smp|kernel-xen)$/DEFAULTKERNEL=kernel/' /etc/sysconfig/kernel || exit $? fi /sbin/new-kernel-pkg --package kernel --mkinitrd --dracut --depmod --install 2.6.31.6-145.fc12.x86_64 || exit $? #if [ -x /sbin/weak-modules ] #then # /sbin/weak-modules --add-kernel 2.6.31.6-145.fc12.x86_64 || exit $? #fi preuninstall scriptlet (using /bin/sh): /sbin/new-kernel-pkg --rminitrd --rmmoddep --remove 2.6.31.6-145.fc12.x86_64 || exit $? #if [ -x /sbin/weak-modules ] #then # /sbin/weak-modules --remove-kernel 2.6.31.6-145.fc12.x86_64 || exit $? #fi posttrans scriptlet (using /bin/sh): /sbin/new-kernel-pkg --package kernel --rpmposttrans 2.6.31.6-145.fc12.x86_64 || exit $? [root@hp550-01 simon]# Created attachment 376013 [details]
Terminal output when running depmod -aev
Hello Pete As you will see in the attached terminal output, depmod only found the 2.6.31.5-127.fc12.x86_64 kernel. rpm -q kernel confirms that both kernels are correctly installed: [root@hp550-01 simon]# rpm -V kernel S.5....T. /boot/initramfs-2.6.31.5-127.fc12.x86_64.img S.5....T. /boot/initramfs-2.6.31.6-145.fc12.x86_64.img [root@hp550-01 simon]# What can be missing? Simon (In reply to comment #6) > Hello Pete > > As you will see in the attached terminal output, depmod only found the > 2.6.31.5-127.fc12.x86_64 kernel. By default depmod only finds the modules for the currently booted kernel, so if you are trying to fix other kernels and can't boot into them.... Well, I think you have to use additional command line options to depmod to tell it what to update. Probably something like: depmod -a /lib/modules/DIR_OF_KERNEL (man depmod for more details) (In reply to comment #7) > (In reply to comment #6) > > Hello Pete > > > > As you will see in the attached terminal output, depmod only found the > > 2.6.31.5-127.fc12.x86_64 kernel. > > By default depmod only finds the modules for the currently booted kernel, so if > you are trying to fix other kernels and can't boot into them.... > > Well, I think you have to use additional command line options to depmod to tell > it what to update. > > Probably something like: > depmod -a /lib/modules/DIR_OF_KERNEL > (man depmod for more details) Hello Fernando I think I need to use depmod's -F switch but I am not sure - It would be nice if Redhat's kernel maintainers would give exact instructions on how repair the faulty installations... The question also arises why did the rpm post script fail to install the module dependences for both the 2.6.31.5-127.fc12.x86_64 kernel in Fedora's upgrade repo and the 2.6.31.6-1.rt19.2.fc12.ccrma.x86_64.rt kernel in ccrma's repo. Simon Kernel can be installed correctly using yum from the command line - yumex has problems running scripts in rpm packages.. *** This bug has been marked as a duplicate of bug 527528 *** |
Created attachment 375552 [details] Boot log Internet access over eth0 is not available when booting with kernel version 2.6.31.6-145.f12.x86_64 The following 2 errors were noted on booting.. 1 modprobe fails 2 Failure to install IP6 tables. Boot process continues and KDE desktop can be started but many operations are prevented due to missing access rights. No obvious problems occur on the same installation when booting with kernel version 22.6.31.5-127.fc12.x86_64.