Bug 544657

Summary: Request of dbus support in pcb
Product: [Fedora] Fedora EPEL Reporter: Max Salov <maksim.salau>
Component: pcbAssignee: Chitlesh GOORAH <chitlesh>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: el5CC: chitlesh, maksim.salau
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 0.20091103-2.el5 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-12-10 04:10:02 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Max Salov 2009-12-05 21:35:01 UTC
Please add '--enable-dbus' to configure options, so pcb and gschem can be used with xgsch2pcb project manager.

Version-Release number of selected component (if applicable):
pcb-0.20091103-1.el5

Thanks in advance.

Comment 1 Chitlesh GOORAH 2009-12-06 13:04:01 UTC
can you please try the rpms from here please ?

http://koji.fedoraproject.org/scratch/chitlesh/task_1852376/

It will be the same rpms that will be pushed to EL-5 repos if it works for you.

Also, did you compile xgsch2pcb from scratch or from a rpm ? We are looking for someone who is willing to give us a hand for that. Are you interested ?

Do I have to rebuild gschem as well ?

Comment 2 Max Salov 2009-12-07 16:51:28 UTC
I've tried new rpm and it works!
I've compiled xgsch2pcb (set of python scripts) from source, because I haven't found rpm. I'm not a maintainer or experienced packager, but I can try. Please help me to start, I have no idea what to do first.
gschem need no rebuild, it works as it is, but somewhat slowly on my machine.

Comment 3 Chitlesh GOORAH 2009-12-07 19:19:23 UTC
Hello Max,

rpm packaging is very easy. I have setup a draft spec file for xgsch2pcb
on https://fedorahosted.org/fedora-electronic-lab/ticket/86

At first, you just need to update the spec exactly the way you would do on the console.

Once you feel that up accordingly,

setup environment with
rpmdev-setuptree

place the sources on ~/rpmbuild/SOURCES and the spec on ~/rpmbuild/SPECS/geda-xgsch2pcb.spec

you can create any rpm with :
rpmbuild -ba ~/rpmbuild/SPECS/geda-xgsch2pcb.spec

once your build is successful, upload your spec file to https://fedorahosted.org/fedora-electronic-lab/ticket/86

Afterwards, I'll guide you through the official fedora packaging process.

Comment 4 Fedora Update System 2009-12-07 20:05:46 UTC
pcb-0.20091103-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/pcb-0.20091103-2.fc11

Comment 5 Fedora Update System 2009-12-07 20:05:51 UTC
pcb-0.20091103-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/pcb-0.20091103-2.fc12

Comment 6 Fedora Update System 2009-12-07 20:05:56 UTC
pcb-0.20091103-2.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/pcb-0.20091103-2.el5

Comment 7 Fedora Update System 2009-12-10 04:01:40 UTC
pcb-0.20091103-2.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pcb'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/EL-5/FEDORA-EPEL-2009-0990

Comment 8 Fedora Update System 2009-12-10 04:09:57 UTC
pcb-0.20091103-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2009-12-10 04:22:23 UTC
pcb-0.20091103-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2009-12-31 06:56:06 UTC
pcb-0.20091103-2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.