Bug 54554

Summary: Xv accellerated video playback does not work in Alpha Cenauri with Radeon
Product: [Retired] Red Hat Linux Reporter: Need Real Name <fredm>
Component: XFree86Assignee: Mike A. Harris <mharris>
Status: CLOSED ERRATA QA Contact: David Lawrence <dkl>
Severity: low Docs Contact:
Priority: medium    
Version: 7.2   
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-12-01 21:40:27 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
XF86Config-4
none
XFree86 log file none

Description Need Real Name 2001-10-12 06:22:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010808

Description of problem:
I am runnning a 1280x1024 desktop, and playing Loki's Alpha Centauri in
1024x768 fullscreen resolution. When movies play in Alpha Centauri, the
game switches to 800x600 resolution and uses the Xv extension to play the
movie. The mode switch does not work properly and shows the image
compressed to the upper 2/3 of the screen only. Disabling SDL's Xv support
allows the switch to work and the movie to play as normal. This worked in
RedHat 7.1

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Configure Alpha Centauri for 1024x768 support
2. Start Alpha Centauri
3. Watch opening movie
	

Actual Results:  You will see the squashed screen (XFree86 reports the mode
switch to have worked, but it does not look right).

Expected Results:  The movie should be centered on the screen and stretch
from the left to the right of the screen.

Additional info:

Hardware:
Athlon 1GHz
ASUS KT133A chipset board
Radeon All-in-wonder card
Dell 1701FP flat panel monitor connected by the DVB-I connector

Software:
Alpha Centauri from Loki with all patches

Comment 1 Mike A. Harris 2001-10-21 21:54:48 UTC
Attach using the link below, your X server logs and config file.

Comment 2 Need Real Name 2001-10-24 01:24:39 UTC
Created attachment 34821 [details]
XF86Config-4

Comment 3 Need Real Name 2001-10-24 01:25:39 UTC
Created attachment 34822 [details]
XFree86 log file

Comment 4 Need Real Name 2001-12-04 03:20:21 UTC
Also happens with release version 7.2

Comment 5 Need Real Name 2002-03-13 00:36:50 UTC
Only occurs in 16bpp, cannot reproduce in 32bpp. On 7.1 worked in 16bpp.

Comment 6 Mike A. Harris 2002-05-21 06:00:35 UTC
Does the problem persist in RHL 7.3?

Comment 7 Need Real Name 2002-05-27 10:43:07 UTC
I tested this in skipjack public beta 2 and it still occurred. Unfortunately I
am no longer running linux on x86 (only on powerpc) and I can no longer test for
this bug.

Comment 8 Mike A. Harris 2002-07-26 10:58:01 UTC
A bug fix for Radeon Xv issues is in rawhide presently which
supposedly fixes this issue.  I'm unable to test this specific
problem personally as I do not have this game available.

Changing state to MODIFIED pending feedback.

I'll assume it works if I haven't heard feedback otherwise in a month
or so.

Thanks.