Bug 546007

Summary: SELinux is preventing /usr/bin/python "read" access on /proc/<pid>/cmdline.
Product: [Fedora] Fedora Reporter: tukeke <tukeke07>
Component: selinux-policyAssignee: Daniel Walsh <dwalsh>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 12CC: dvitale, dwalsh, gevsantos, mgrepl
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard: setroubleshoot_trace_hash:7dd28c6a7f2a61d8f567546551baed20c50e06d2ac014e1bb22f906e7c73789c
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-12-22 20:42:15 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description tukeke 2009-12-09 19:21:10 UTC
Resúmen:

SELinux is preventing /usr/bin/python "read" access on /proc//cmdline.

Descripción Detallada:

[system-config-f es un tipo permisivo (firewallgui_t). Este acceso no fue
denegado.]

SELinux denied access requested by system-config-f. It is not expected that this
access is required by system-config-f and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Permitiendo Acceso:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Información Adicional:

Contexto Fuente               system_u:system_r:firewallgui_t:s0-s0:c0.c1023
Contexto Destino              unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
                              023
Objetos Destino               /proc/<pid>/cmdline [ file ]
Fuente                        system-config-f
Dirección de Fuente          /usr/bin/python
Puerto                        <Desconocido>
Nombre de Equipo              (removed)
Paquetes RPM Fuentes          python-2.6.2-2.fc12
Paquetes RPM Destinos         
RPM de Políticas             selinux-policy-3.6.32-55.fc12
SELinux Activado              True
Tipo de Política             targeted
Modo Obediente                Enforcing
Nombre de Plugin              catchall
Nombre de Equipo              (removed)
Plataforma                    Linux (removed) 2.6.31.6-145.fc12.i686 #1 SMP Sat
                              Nov 21 16:28:23 EST 2009 i686 i686
Cantidad de Alertas           1
Visto por Primera Vez         mié 09 dic 2009 14:46:22 VET
Visto por Última Vez         mié 09 dic 2009 14:46:22 VET
ID Local                      10790464-b572-41a7-92fd-15fbdcbc9854
Números de Línea            

Mensajes de Auditoría Crudos 

node=(removed) type=AVC msg=audit(1260386182.743:41): avc:  denied  { read } for  pid=12138 comm="system-config-f" path="/proc/2432/cmdline" dev=proc ino=29238 scontext=system_u:system_r:firewallgui_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=file

node=(removed) type=SYSCALL msg=audit(1260386182.743:41): arch=40000003 syscall=11 success=yes exit=0 a0=99b9068 a1=99b8c20 a2=99b8008 a3=99bb1e8 items=0 ppid=12137 pid=12138 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="system-config-f" exe="/usr/bin/python" subj=system_u:system_r:firewallgui_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  selinux-policy-3.6.32-55.fc12,catchall,system-config-f,firewallgui_t,unconfined_t,file,read
audit2allow suggests:

#============= firewallgui_t ==============
allow firewallgui_t unconfined_t:file read;

Comment 1 Daniel Walsh 2009-12-09 19:31:10 UTC
I think these avc's are happening because firewallgui is being blocked from sending dbus messages to unconfined_t.


You can add these rules for now using

# grep avc /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Fixed in selinux-policy-3.6.32-57.fc12.noarch

Comment 2 Fedora Update System 2009-12-16 13:53:29 UTC
selinux-policy-3.6.32-59.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/selinux-policy-3.6.32-59.fc12

Comment 3 Fedora Update System 2009-12-18 04:41:43 UTC
selinux-policy-3.6.32-59.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update selinux-policy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-13384