This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 548116

Summary: cannot create a headless KVM virtual machine
Product: [Fedora] Fedora Reporter: Jeff Bastian <jbastian>
Component: libvirtAssignee: Daniel Veillard <veillard>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 12CC: berrange, clalance, crobinso, itamar, jforbes, liko, veillard, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 548127 (view as bug list) Environment:
Last Closed: 2010-05-12 11:10:51 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 548127    

Description Jeff Bastian 2009-12-16 12:03:36 EST
Description of problem:
virt-install cannot create a headless machine, i.e., no virtual VGA card.

The --nographics option does not start the graphical console, but it still creates a virtual Cirrus VGA card for the guest.

The --video option does not let you specify 'none' as an option.  It gives a Python traceback and
   ERROR    internal error unknown video model 'none'

You can create a headless machine with qemu-kvm directly by specifying '-nographic -vga none'.

Please let 'virt-install --nographics --video=none ...' create a headless virtual machine with no VGA card.


Version-Release number of selected component (if applicable):
python-virtinst-0.500.0-5.fc12

How reproducible:
every time

Steps to Reproduce:
1. virt-install --nographics --video=none ...
  
Actual results:
ERROR    internal error unknown video model 'none'

Expected results:
create a virtual machine with no VGA card like 'qemu-kvm -nographic -vga none'

Additional info:
Comment 1 Jeff Bastian 2009-12-16 12:12:02 EST
For reference, here's my full qemu-kvm command I used when testing:

qemu-kvm \
   -name rhel54-headless \
   -m 512 \
   -hda /var/lib/libvirt/images/rhel54-headless.img \
   -net nic,model=virtio \
   -net user \
   -nographic \
   -vga none \
   -serial stdio \
   -kernel /..../RHEL-5-Server/U4/x86_64/os/images/pxeboot/vmlinuz \
   -initrd /..../RHEL-5-Server/U4/x86_64/os/images/pxeboot/initrd.img \
   -append "console=ttyS0 serial vnc"
Comment 2 Daniel Berrange 2009-12-16 12:17:12 EST
The --nographics option to virt-install should already be turning off the VGA card. That it doesn't is a bug in libvirt, we were unable to solve in the past since '-vga' did not exist in QEMU. We can solve it now, with -vga none.
There's no need for any other args in virt-install itself.
Comment 3 Cole Robinson 2010-05-12 11:10:51 EDT
The qemu -device work facilitating this in libvirt was extensive and could not be backported to F12, so this will only work in F13 and later. Closing as RAWHIDE.