Bug 550217

Summary: no self test on seiko epson model j251a perfection v500 photo scanner that used to work
Product: [Fedora] Fedora Reporter: collura
Component: sane-backendsAssignee: Nils Philippsen <nphilipp>
Status: CLOSED CANTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 12CC: collura, nphilipp, spacewar
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-04-07 11:31:18 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
some command responses inquiring about the status of epson scanner which xsane cant seem to find anylonger
none
parts of dmesg, lsusb, lshal from fc12
none
epson is there but sane wont scan from it anymore
none
working epson v500 aka gt-x770 aka usbid-vendor=0x04b8 usbid-product=0x0130 none

Description collura 2009-12-23 21:49:11 EST
Created attachment 380121 [details]
some command responses inquiring about the status of epson scanner which xsane cant seem to find anylonger

Description of problem:
this scanner used to work a month or so ago with various programs including xsane and worked pretty well.  i thought i had a motor failure until i broke down and installed driver on a mswindows installation where the scanner works just fine including boottime micropositioner test (whir sound).

tried scanner on machines with: 
kernel 2.6.30.9-102.fc11.x86_64 gnome 2.26 (see attachment for fc11 machine)
kernel 2.6.31.6-166.fc12.x86_64 gnome 2.28


Version-Release number of selected component (if applicable):

kernel 2.6.30.9-102.fc11.x86_64 
sane-backends-1.0.20-4.fc11 (x86_64)
sane-backends-devel-1.0.20-4.fc11 (x86_64)
sane-backends-libs-1.0.20-4.fc11 (x86_64)
sane-backends-libs-gphoto2-1.0.20-4.fc11 (x86_64)
xsane-0.997-1.fc11 (x86_64)
xsane-gimp-0.997-1.fc11 (x86_64)
(at one point had installed iscan-2.23.0-3.ltdl7 (x86_64)  <---from avayasys not fedora)
(at one point had installed iscan-firmware-2.1.0-3.fc11 (noarch) )

[have similar results on fc12 machine]

How reproducible:
always

Steps to Reproduce:
1. boot with scanner on or plug in after booted or turn on before or after boot
2. run xsane or another program that used to generate scan
3. get error message about no devices attached ( but seems to show up fine in attached logs )
  
Actual results:
scanner worked fine a few updates ago but seems to have lost connection now.

xsane gives: "no devices available"

no micropositioner check at startup ( used to work ).

same device works on mswindowsvista32 currently but just not in fedora.


Expected results:
micropositioner motors sound when boot machine or turn on scanner.
xsane to see device.
xsane to scan an image from seen device.

Additional info:

i gather there has been alot of kernel work related to drivers lately but am not sure whether to report this against kernel or sane or what.  i expect kernel since power on startup test of micropositioner no longer seems to run and since saw a lot of kernel updates going through lately.  if this should be reported against some other part then please suggest.

did i forget to enable a service after some update?
i have had several similar 'device not found errors' ( screen brightness control, gps receiver, now this scanner ) in the last few months while lsusb and such seem to see the devices and they used to work at some point.  saw a note talking about now kernel architecture for drivers is mid-change but dont know how to differentiate among kernel, hal, backend, frontend sources.
Comment 1 Nils Philippsen 2009-12-29 07:26:28 EST
Did this device ever work in Fedora 12?
Comment 2 collura 2009-12-29 10:23:02 EST
No, i have never had it work with fc12, but i have only tried it recently when i found i had problems with fc11 so i am not sure that tells you as much as you might hope.
Comment 3 collura 2009-12-29 16:36:15 EST
Created attachment 380853 [details]
parts of dmesg, lsusb, lshal from fc12
Comment 4 Eric Smith 2010-01-28 18:57:13 EST
I have the same problem with an Epson Perfection 3590 scanner on F12.  It worked in earlier Fedora releases (F9 and F10, I think, but I probably didn't try it in F11).  It appears to be a permissions problem, as xsane finds it just fine when run as root.

The Epson 3590 scanner is listed in /lib/udev/rules.d/65-libsane.rules, and I verified that the idVendor and idProduct are correct.

lsusb output excerpt:
Bus 002 Device 007: ID 04b8:0122 Seiko Epson Corp. Perfection 3590 scanner
Comment 5 collura 2010-02-03 13:32:35 EST
i dont know if i am just thick or if this is new but i just noticed that when i start xsane on fc11 the window title has the device name in it and that device is a webcam not the scanner.

i ran the attached commands and it looks like the epson scanner is detected by sane-find-scanner but not by scanimage both for normal user and for root?

so this means that the scanimage program has lost capability for epson?

i dont see what in the configuration files would select the webcam over the epson as they are both listed in the various files but that kind of seems to be whats going on either by selection or by limitation.

i will attach the scanimage and sane-find-scanner command results.

the current kernel is kernel-2.6.30.10-105.2.4.fc11 (x86_64)
Comment 6 collura 2010-02-03 13:34:09 EST
Created attachment 388588 [details]
epson is there but sane wont scan from it anymore
Comment 7 collura 2010-02-03 13:57:53 EST
on an fc12 system the scanimage and sane-find-scanner results were similar.
fc12 system was running kernel 2.6.31.12-174.2.3.fc12 (x86_64) and sane-backends version 1.0.20 as well
Comment 8 collura 2010-04-06 13:30:33 EDT
device is successfully scanning now.

went with closed driver plugin so scanner up for now with 

    currently:
      kernel 2.6.32.10-90.fc12.x86_64 gnome 2.28.2
      sane-backends-1.0.20-11.fc12 (x86_64)
      sane-backends-libs-1.0.20-11.fc12 (x86_64)
      xsane-0.997-3.fc12 (x86_64)
      xsane-common-0.997-3.fc12 (x86_64)
      xsane-gimp-0.997-3.fc12 (x86_64)

    grudginly installing (no offense avasys, much appreciated)
      www.avasys.jp: iscan-2.24.0-4.ltdl7 (x86_64)
      www.avasys.jp: iscan-plugin-gt-x770-2.1.1-2.c2 (x86_64)

(see attached)


0) from what i read the closed plugin translates a nonstandard seiko/epson communication protocol that the sane-backend doesnt understand because its closed? : 

http://lists.alioth.debian.org/pipermail/sane-devel/2007-October/020047.html 
Olaf:"The Perfection V500 does not speak the protocol that the epson backend
assumes.  There is just about zero chance that it will work with any
of the other backends that support EPSON devices (snapscan, plustek).
If support for this scanner is added to the epkowa backend, then it
will require a plugin which takes care of the protocol conversion.
"


1) so that means that the system was initially working because i had the protocol conversion plugin installed maybe?

the breakage was due to change in plugin install/update status maybe?

so installing the closed plugin fixed the scanner?


2) while rechecking sane site for support status at

http://www.sane-project.org/lists/sane-mfgs-cvs.html

lists the epson perfection v500 ( aka GT-x770 aka usbID=0x04b8/0x0130 ) as 
'unsupported go to www.avasys.jp 
for closed driver plugin (http://www.avasys.jp/lx-bin2/linux/scan/DL1.do)'

so i temporarily give up and grudginly installed the closed plugin
and now scanner is up again but this solution is not cool.


3) i dont know if i only had it working originally by virtue of the closed plugin 
or if something changed 
but that is where we are now...

maybe there is more to the issue than i understand but 
not real happy about this from an open-ness standpoint.

i dont have time to mess further with this now as i have a scan backlog to clear now that the scanner is up.

however, guess i need to shop for a more open scanner when time allows.
Comment 9 collura 2010-04-06 13:34:22 EDT
Created attachment 404760 [details]
working epson v500 aka gt-x770 aka usbid-vendor=0x04b8 usbid-product=0x0130

epson v500 aka gt-x770 aka usbid-vendor=0x04b8 usbid-product=0x0130 
absolutely needs closed plugin to work?
Comment 10 Nils Philippsen 2010-04-07 11:31:18 EDT
(In reply to comment #8)
> 2) while rechecking sane site for support status at
> 
> http://www.sane-project.org/lists/sane-mfgs-cvs.html
> 
> lists the epson perfection v500 ( aka GT-x770 aka usbID=0x04b8/0x0130 ) as 
> 'unsupported go to www.avasys.jp 
> for closed driver plugin (http://www.avasys.jp/lx-bin2/linux/scan/DL1.do)'
> 
> so i temporarily give up and grudginly installed the closed plugin
> and now scanner is up again but this solution is not cool.

Aw that sucks. Not much I or SANE upstream can do then I suppose unless Epson opens up specs...
Comment 11 collura 2010-04-07 11:43:32 EDT
*nod*
Comment 12 collura 2010-04-16 02:10:51 EDT
i ran across this post.  it sure sounds like it fits : 

Message: 6 Date: Thu, 15 Apr 2010 17:32:23 +0200 
From: Julien BLACHE <jb@jblache.org> 
Subject: Re: [sane-devel] [Regression] libsane-extras doesn't work any more with EPSON PM-A820 
To: Yann Ubuntu <yannubuntu@gmail.com> Cc: sane-devel@lists.alioth.debian.org Message-ID: <877ho8pw8o.fsf@sonic.technologeek.org> 
Content-Type: text/plain; charset=us-ascii Yann Ubuntu <yannubuntu@gmail.com> wrote: Hi,
> > libsane-extras Jaunty was working well with my EPSON PM-A820, but it
> > does not in Karmic (and Lucid).
If you were relying on the epkowa backend, it's been removed from
libsane-extras a while ago already.

You'll need to get it from the Avasys website directly.

JB.

-- Julien BLACHE <http://www.jblache.org> <jb@jblache.org> GPG KeyID 0xF5D65169
Comment 13 collura 2010-04-27 13:36:41 EDT
more to the point:

------------------------------ Message: 7 Date: Mon, 26 Apr 2010 20:01:39 +0900 From: Yann Ubuntu <yannubuntu@gmail.com> Subject: Re: [sane-devel] [Regression] libsane-extras doesn't work any more with EPSON PM-A820 To: sane-devel@lists.alioth.debian.org Message-ID: <v2iff483ee01004260401kff42771fy5466dd8f77527da9@mail.gmail.com> Content-Type: text/plain; charset=ISO-8859-1 2010/4/16 Julien BLACHE <jb@jblache.org>:
> > Yann Ubuntu <yannubuntu@gmail.com> wrote:
> >
> > Hi,
> >
>> >> libsane-extras Jaunty was working well with my EPSON PM-A820, but it
>> >> does not in Karmic (and Lucid).
> >
> > If you were relying on the epkowa backend, it's been removed from
> > libsane-extras a while ago already.
> >
> > You'll need to get it from the Avasys website directly.
> >
> > JB.
> >
Thank you Julien and Allan for your answers.

@Allan: where can I contact the developpers of libsane-extras ?

@Julien: is epkowa a driver ? has it been removed because of its
licence ? (non-free?)
The drivers available on Avasys website are all epkowa type? (On the
"All-in-one" page of the Avasys website there is no PM-A820 driver. )

Regards,
~YannUbuntu



------------------------------

------------------------------

_______________________________________________
sane-devel mailing list
sane-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/sane-devel

End of sane-devel Digest, Vol 58, Issue 32
******************************************


.... and .....


------------------------------ Message: 8 Date: Mon, 26 Apr 2010 17:45:31 +0200 From: Julien BLACHE <jb@jblache.org> Subject: Re: [sane-devel] [Regression] libsane-extras doesn't work any more with EPSON PM-A820 To: sane-devel@lists.alioth.debian.org Message-ID: <87k4ru2p5w.fsf@sonic.technologeek.org> Content-Type: text/plain; charset=us-ascii Yann Ubuntu <yannubuntu@gmail.com> wrote: Hi,
> > @Allan: where can I contact the developpers of libsane-extras ?
I am the maintainer of libsane-extras.

> > @Julien: is epkowa a driver ? has it been removed because of its
> > licence ? (non-free?)
It's free, but it depends on non-free, binary-only plugins. It's been
removed at the request of Avasys when they started providing Debian
packages and I got fed up dealing with a number of issues with epkowa
(most notably ABI changes for the binary plugins).

> > The drivers available on Avasys website are all epkowa type? (On the
> > "All-in-one" page of the Avasys website there is no PM-A820 driver. )
Yes, epkowa is Epson's backend for all their models. If your model is
not listed, then it's not supported AFAICT.

JB.

-- Julien BLACHE <http://www.jblache.org> <jb@jblache.org> GPG KeyID 0xF5D65169 ------------------------------ _______________________________________________ 
sane-devel mailing list sane-devel@lists.alioth.debian.org 
http://lists.alioth.debian.org/mailman/listinfo/sane-devel 

End of sane-devel Digest, Vol 58, Issue 33 
******************************************