Bug 550951

Summary: SELinux is preventing /usr/bin/qemu "read write" access on 004.
Product: [Fedora] Fedora Reporter: fredouille <f.berard>
Component: libvirtAssignee: Daniel Veillard <veillard>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 12CC: berrange, clalance, crobinso, dwalsh, f.berard, giosif, itamar, jforbes, mgrepl, veillard, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard: setroubleshoot_trace_hash:9df20856220ecb84359284734c0f1fec933db2b64f0172cca6a583038b4a8e9c
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-03-16 12:05:43 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description fredouille 2009-12-28 04:18:37 EST
Résumé:

SELinux is preventing /usr/bin/qemu "read write" access on 004.

Description détaillée:

SELinux denied access requested by qemu. It is not expected that this access is
required by qemu and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Autoriser l'accès:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Informations complémentaires:

Contexte source               system_u:system_r:svirt_t:s0:c365,c655
Contexte cible                system_u:object_r:usb_device_t:s0
Objets du contexte            004 [ chr_file ]
source                        qemu
Chemin de la source           /usr/bin/qemu
Port                          <Inconnu>
Hôte                         (removed)
Paquetages RPM source         qemu-system-x86-0.11.0-12.fc12
Paquetages RPM cible          
Politique RPM                 selinux-policy-3.6.32-59.fc12
Selinux activé               True
Type de politique             targeted
Mode strict                   Enforcing
Nom du plugin                 catchall
Nom de l'hôte                (removed)
Plateforme                    Linux (removed) 2.6.31.9-174.fc12.x86_64
                              #1 SMP Mon Dec 21 05:33:33 UTC 2009 x86_64 x86_64
Compteur d'alertes            1
Première alerte              dim. 27 déc. 2009 16:23:48 CET
Dernière alerte              dim. 27 déc. 2009 16:23:48 CET
ID local                      0fb7d9a8-ffb6-4908-af3f-cc871bf196bb
Numéros des lignes           

Messages d'audit bruts        

node=(removed) type=AVC msg=audit(1261927428.241:36): avc:  denied  { read write } for  pid=4330 comm="qemu" name="004" dev=tmpfs ino=237799 scontext=system_u:system_r:svirt_t:s0:c365,c655 tcontext=system_u:object_r:usb_device_t:s0 tclass=chr_file

node=(removed) type=SYSCALL msg=audit(1261927428.241:36): arch=c000003e syscall=2 success=no exit=-13 a0=7fff47724690 a1=802 a2=7fff477246a4 a3=fffffff4 items=0 ppid=1 pid=4330 auid=4294967295 uid=107 gid=107 euid=107 suid=107 fsuid=107 egid=107 sgid=107 fsgid=107 tty=(none) ses=4294967295 comm="qemu" exe="/usr/bin/qemu" subj=system_u:system_r:svirt_t:s0:c365,c655 key=(null)



Hash String generated from  selinux-policy-3.6.32-59.fc12,catchall,qemu,svirt_t,usb_device_t,chr_file,read,write
audit2allow suggests:

#============= svirt_t ==============
allow svirt_t usb_device_t:chr_file { read write };
Comment 1 Daniel Walsh 2009-12-29 18:37:51 EST
This looks like libvirt failed to label the usb device.
Comment 2 Daniel Walsh 2010-02-03 14:10:18 EST
*** Bug 561494 has been marked as a duplicate of this bug. ***
Comment 3 Cole Robinson 2010-03-16 12:05:43 EDT
Pretty sure this is a symptom of bug 537227

*** This bug has been marked as a duplicate of bug 537227 ***