Bug 551460

Summary: SELinux is preventing /usr/sbin/nmbd access to a leaked /root/.xsession-errors file descriptor.
Product: [Fedora] Fedora Reporter: Bob hernandez <bhernco>
Component: selinux-policyAssignee: Daniel Walsh <dwalsh>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 12CC: bhernco, dwalsh, mgrepl
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard: setroubleshoot_trace_hash:569ff5732e302de26a072ff4049f44c3191a2499fddc8a166937f2836b32685c
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-12-31 13:46:45 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Bob hernandez 2009-12-30 20:49:32 UTC
Summary:

SELinux is preventing /usr/sbin/nmbd access to a leaked /root/.xsession-errors
file descriptor.

Detailed Description:

[nmbd has a permissive type (nmbd_t). This access was not denied.]

SELinux denied access requested by the nmbd command. It looks like this is
either a leaked descriptor or nmbd output was redirected to a file it is not
allowed to access. Leaks usually can be ignored since SELinux is just closing
the leak and reporting the error. The application does not use the descriptor,
so it will run properly. If this is a redirection, you will not get output in
the /root/.xsession-errors. You should generate a bugzilla on selinux-policy,
and it will get routed to the appropriate package. You can safely ignore this
avc.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385)

Additional Information:

Source Context                unconfined_u:system_r:nmbd_t:s0
Target Context                unconfined_u:object_r:admin_home_t:s0
Target Objects                /root/.xsession-errors [ file ]
Source                        nmbd
Source Path                   /usr/sbin/nmbd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           samba-3.4.2-47.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-59.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   leaks
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31.9-174.fc12.i686 #1 SMP
                              Mon Dec 21 06:24:20 UTC 2009 i686 i686
Alert Count                   3
First Seen                    Wed 30 Dec 2009 10:47:53 AM HST
Last Seen                     Wed 30 Dec 2009 10:48:29 AM HST
Local ID                      ad3b5307-1254-48f7-8a67-84c90e1ca184
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1262206109.853:226): avc:  denied  { write } for  pid=7306 comm="nmbd" path="/root/.xsession-errors" dev=dm-0 ino=67018 scontext=unconfined_u:system_r:nmbd_t:s0 tcontext=unconfined_u:object_r:admin_home_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1262206109.853:226): arch=40000003 syscall=11 success=yes exit=0 a0=905dbc8 a1=905db48 a2=905d230 a3=905db48 items=0 ppid=7305 pid=7306 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=22 comm="nmbd" exe="/usr/sbin/nmbd" subj=unconfined_u:system_r:nmbd_t:s0 key=(null)



Hash String generated from  selinux-policy-3.6.32-59.fc12,leaks,nmbd,nmbd_t,admin_home_t,file,write
audit2allow suggests:
audit2allow is not installed.

Comment 1 Daniel Walsh 2009-12-31 13:46:45 UTC

*** This bug has been marked as a duplicate of bug 543970 ***