Bug 55208

Summary: linuxrc commands in wrong order mouting /proc
Product: [Retired] Red Hat Linux Reporter: Philip Pokorny <ppokorny>
Component: mkinitrdAssignee: Matt Wilson <msw>
Status: CLOSED RAWHIDE QA Contact: David Lawrence <dkl>
Severity: low Docs Contact:
Priority: medium    
Version: 7.2   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2001-12-19 13:50:55 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
It seems I'm not the first one to notice, so FWIW, here is a patch. RH? AYT? none

Description Philip Pokorny 2001-10-27 06:56:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; SunOS 5.6 i86pc)

Description of problem:
When mkinitrd builds a ram-disk, the linuxrc script that is written has the
echo and mount commands for /proc backwards.  The mount command preceeds
the echo.  All other commands have the echo preceeding the actual command.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. mkinitrd --nocompress /tmp/foo.img 2.4.7---
2. mount -o loop /tmp/foo.img /mnt/floppy
3. cat /mnt/floppy/linuxrc


Actual Results:  mount /proc
echo Mounting /proc filesystem

Expected Results:  echo Mounting /proc filesystem
mount /proc

Additional info:

Comment 1 Miloslav Trmac 2001-12-19 13:50:51 UTC
Created attachment 41027 [details]
It seems I'm not the first one to notice, so FWIW, here is a patch. RH? AYT?

Comment 2 Erik Troan 2002-01-11 16:19:35 UTC
Fixed in CVS (mkinitrd 3.3 should show up in rawhide shortly).