This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 552672

Summary: BCM57780 NIC doesn't work:
Product: [Fedora] Fedora Reporter: John Levon <levon>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 12CC: anton, biaji.cn, dougsland, gansalmon, itamar, jruemker, kernel-maint
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-03-15 12:59:40 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description John Levon 2010-01-05 15:30:33 EST
Description of problem:

On my Dell Precision T1500, I have this NIC:

02:00.0 Ethernet controller: Broadcom Corporation NetLink BCM57780 Gigabit Ethernet PCIe (rev 01)

This doesn't work:

Jan  3 17:35:08 localhost kernel: tg3.c:v3.99 (April 20, 2009)
Jan  3 17:35:08 localhost kernel: tg3 0000:02:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
Jan  3 17:35:08 localhost kernel: tg3 0000:02:00.0: PME# disabled
Jan  3 17:35:08 localhost kernel: tg3 mdio bus: probed
Jan  3 17:35:08 localhost kernel: eth%d: No PHY devices
Jan  3 17:35:08 localhost kernel: tg3: Problem fetching invariants of chip, aborting.
Jan  3 17:35:08 localhost kernel: tg3 0000:02:00.0: PCI INT A disabled


Version-Release number of selected component (if applicable):

kernel-2.6.31.9-174.fc12.x86_64

How reproducible:

Every time.

A workaround is this:

rmmod tg3
modprobe broadcom
modprobe tg3

However, this also causes this (apparently harmless) oops:

Jan  3 20:34:54 localhost kernel: eth1: Tigon3 [partno(BCM57780) rev 57780001] (PCI Express) MAC address 00:25:64:8c:2e:b3
Jan  3 20:34:54 localhost kernel: eth1: attached PHY driver [Broadcom BCM57780] (mii_bus:phy_addr=200:01)
Jan  3 20:34:54 localhost kernel: eth1: RXcsums[1] LinkChgREG[0] MIirq[0] ASF[0] TSOcap[1]
Jan  3 20:34:54 localhost kernel: eth1: dma_rwctrl[76180000] dma_mask[64-bit]
Jan  3 20:34:55 localhost NetworkManager: <info>  (eth1): carrier is OFF
Jan  3 20:34:55 localhost NetworkManager: <info>  (eth1): new Ethernet device (driver: 'tg3')
Jan  3 20:34:55 localhost NetworkManager: <info>  (eth1): exported as /org/freedesktop/NetworkManager/Devices/1
Jan  3 20:34:55 localhost NetworkManager: <info>  (eth1): now managed
Jan  3 20:34:55 localhost NetworkManager: <info>  (eth1): device state change: 1 -> 2 (reason 2)
Jan  3 20:34:55 localhost NetworkManager: <info>  (eth1): bringing up device.
Jan  3 20:34:55 localhost kernel: tg3 0000:02:00.0: PME# disabled
Jan  3 20:34:55 localhost kernel: BUG: sleeping function called from invalid context at kernel/mutex.c:94
Jan  3 20:34:55 localhost kernel: in_atomic(): 1, irqs_disabled(): 0, pid: 1273, name: NetworkManager
Jan  3 20:34:55 localhost kernel: Pid: 1273, comm: NetworkManager Tainted: P           2.6.31.9-174.fc12.x86_64 #1
Jan  3 20:34:55 localhost kernel: Call Trace:
Jan  3 20:34:55 localhost kernel: [<ffffffff8104026a>] __might_sleep+0xe6/0xe8
Jan  3 20:34:55 localhost kernel: [<ffffffff8141c724>] mutex_lock+0x22/0x4e
Jan  3 20:34:55 localhost kernel: [<ffffffffa0c0aff3>] ? tg3_nvram_lock+0x3e/0x7d [tg3]
Jan  3 20:34:55 localhost kernel: [<ffffffffa0c0fcb2>] tg3_chip_reset+0x33/0x6ff [tg3]
Jan  3 20:34:55 localhost kernel: [<ffffffffa0c15fab>] tg3_reset_hw+0x6a/0x1581 [tg3]
Jan  3 20:34:55 localhost kernel: [<ffffffffa0c174f1>] tg3_init_hw+0x2f/0x34 [tg3]
Jan  3 20:34:55 localhost kernel: [<ffffffffa0c17eb7>] tg3_open+0x380/0x685 [tg3]
Jan  3 20:34:55 localhost kernel: [<ffffffff81380440>] dev_open+0x9d/0xd8
Jan  3 20:34:55 localhost kernel: [<ffffffff8137fb9d>] dev_change_flags+0xad/0x16e
Jan  3 20:34:55 localhost kernel: [<ffffffff81389009>] do_setlink+0x28e/0x35f
Jan  3 20:34:55 localhost kernel: [<ffffffff813891ed>] rtnl_setlink+0x113/0x126
Jan  3 20:34:55 localhost kernel: [<ffffffff81388a32>] rtnetlink_rcv_msg+0x1c6/0x1e3
Jan  3 20:34:55 localhost kernel: [<ffffffff8138886c>] ? rtnetlink_rcv_msg+0x0/0x1e3
Jan  3 20:34:55 localhost kernel: [<ffffffff81399fc2>] netlink_rcv_skb+0x43/0x95
Jan  3 20:34:55 localhost kernel: [<ffffffff81388865>] rtnetlink_rcv+0x26/0x2d
Jan  3 20:34:55 localhost kernel: [<ffffffff81399b0b>] netlink_unicast+0x125/0x18e
Jan  3 20:34:55 localhost kernel: [<ffffffff81399df3>] netlink_sendmsg+0x27f/0x28e
Jan  3 20:34:55 localhost kernel: [<ffffffff8136eddb>] __sock_sendmsg+0x61/0x6c
Jan  3 20:34:55 localhost kernel: [<ffffffff8136f552>] sock_sendmsg+0xcc/0xe5
Jan  3 20:34:55 localhost kernel: [<ffffffff8136f41c>] ? sock_recvmsg+0xcf/0xe8
Jan  3 20:34:55 localhost kernel: [<ffffffff81067b37>] ? autoremove_wake_function+0x0/0x39
Jan  3 20:34:55 localhost kernel: [<ffffffff81067b37>] ? autoremove_wake_function+0x0/0x39
Jan  3 20:34:55 localhost kernel: [<ffffffff81370109>] ? move_addr_to_kernel+0x48/0x4d
Jan  3 20:34:55 localhost kernel: [<ffffffff813789ab>] ? verify_iovec+0x51/0x8e
Jan  3 20:34:55 localhost kernel: [<ffffffff8136f78c>] sys_sendmsg+0x221/0x2a5
Jan  3 20:34:55 localhost kernel: [<ffffffff810f1b05>] ? virt_to_head_page+0xe/0x2f
Jan  3 20:34:55 localhost kernel: [<ffffffff8136ee97>] ? sockfd_lookup_light+0x20/0x58
Jan  3 20:34:55 localhost kernel: [<ffffffff81370233>] ? sys_sendto+0x125/0x152
Jan  3 20:34:55 localhost kernel: [<ffffffff810fdb75>] ? __fput+0x1cb/0x1da
Jan  3 20:34:55 localhost kernel: [<ffffffff8110447d>] ? path_put+0x22/0x27
Jan  3 20:34:55 localhost kernel: [<ffffffff81095ed8>] ? audit_syscall_entry+0x11e/0x14a
Jan  3 20:34:55 localhost kernel: [<ffffffff81011cf2>] system_call_fastpath+0x16/0x1b
Jan  3 20:34:55 localhost kernel: BUG: scheduling while atomic: NetworkManager/1273/0x10000100
Jan  3 20:34:55 localhost kernel: Modules linked in: tg3 broadcom ppdev parport_pc lp parport nls_utf8 fuse sunrpc ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 cpufreq_ondemand acpi_cpufreq freq_table dm_multipath uinput snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm nvidia(P) snd_timer snd 8139too soundcore 8139cp snd_page_alloc i2c_i801 dcdbas mii nouveau ttm drm_kms_helper drm i2c_algo_bit i2c_core [last unloaded: tg3]
Jan  3 20:34:55 localhost kernel: Pid: 1273, comm: NetworkManager Tainted: P           2.6.31.9-174.fc12.x86_64 #1
Jan  3 20:34:55 localhost kernel: Call Trace:
Jan  3 20:34:55 localhost kernel: [<ffffffff81048fb6>] __schedule_bug+0x61/0x65
Jan  3 20:34:55 localhost kernel: [<ffffffff8141b600>] schedule+0xb3/0x7f2
Jan  3 20:34:55 localhost kernel: [<ffffffff8120d04a>] ? pci_bus_read_config_byte+0x68/0x76
Jan  3 20:34:55 localhost kernel: [<ffffffff810126ce>] ? common_interrupt+0xe/0x13
Jan  3 20:34:55 localhost kernel: [<ffffffff8104b94d>] __cond_resched+0x32/0x5b
Jan  3 20:34:55 localhost kernel: [<ffffffff8141bebf>] _cond_resched+0x2c/0x37
Jan  3 20:34:55 localhost kernel: [<ffffffff8141c729>] mutex_lock+0x27/0x4e
Jan  3 20:34:55 localhost kernel: [<ffffffffa0c0babf>] ? tg3_read_mem+0xd1/0xdd [tg3]
Jan  3 20:34:55 localhost kernel: [<ffffffffa0c0fc1a>] tg3_mdio_start+0x2a/0x8f [tg3]
Jan  3 20:34:55 localhost kernel: [<ffffffffa0c102b8>] tg3_chip_reset+0x639/0x6ff [tg3]
Jan  3 20:34:55 localhost kernel: [<ffffffffa0c15fab>] tg3_reset_hw+0x6a/0x1581 [tg3]
Jan  3 20:34:55 localhost kernel: [<ffffffffa0c174f1>] tg3_init_hw+0x2f/0x34 [tg3]
Jan  3 20:34:55 localhost kernel: [<ffffffffa0c17eb7>] tg3_open+0x380/0x685 [tg3]
Jan  3 20:34:55 localhost kernel: [<ffffffff81380440>] dev_open+0x9d/0xd8
Jan  3 20:34:55 localhost kernel: [<ffffffff8137fb9d>] dev_change_flags+0xad/0x16e
Jan  3 20:34:55 localhost kernel: [<ffffffff81389009>] do_setlink+0x28e/0x35f
Jan  3 20:34:55 localhost kernel: [<ffffffff813891ed>] rtnl_setlink+0x113/0x126
Jan  3 20:34:55 localhost kernel: [<ffffffff81388a32>] rtnetlink_rcv_msg+0x1c6/0x1e3
Jan  3 20:34:55 localhost kernel: [<ffffffff8138886c>] ? rtnetlink_rcv_msg+0x0/0x1e3
Jan  3 20:34:55 localhost kernel: [<ffffffff81399fc2>] netlink_rcv_skb+0x43/0x95
Jan  3 20:34:55 localhost kernel: [<ffffffff81388865>] rtnetlink_rcv+0x26/0x2d
Jan  3 20:34:55 localhost kernel: [<ffffffff81399b0b>] netlink_unicast+0x125/0x18e
Jan  3 20:34:55 localhost kernel: [<ffffffff81399df3>] netlink_sendmsg+0x27f/0x28e
Jan  3 20:34:55 localhost kernel: [<ffffffff8136eddb>] __sock_sendmsg+0x61/0x6c
Jan  3 20:34:55 localhost kernel: [<ffffffff8136f552>] sock_sendmsg+0xcc/0xe5
Jan  3 20:34:55 localhost kernel: [<ffffffff8136f41c>] ? sock_recvmsg+0xcf/0xe8
Jan  3 20:34:55 localhost kernel: [<ffffffff81067b37>] ? autoremove_wake_function+0x0/0x39
Jan  3 20:34:55 localhost kernel: [<ffffffff81067b37>] ? autoremove_wake_function+0x0/0x39
Jan  3 20:34:55 localhost kernel: [<ffffffff81370109>] ? move_addr_to_kernel+0x48/0x4d
Jan  3 20:34:55 localhost kernel: [<ffffffff813789ab>] ? verify_iovec+0x51/0x8e
Jan  3 20:34:55 localhost kernel: [<ffffffff8136f78c>] sys_sendmsg+0x221/0x2a5
Jan  3 20:34:55 localhost kernel: [<ffffffff810f1b05>] ? virt_to_head_page+0xe/0x2f
Jan  3 20:34:55 localhost kernel: [<ffffffff8136ee97>] ? sockfd_lookup_light+0x20/0x58
Jan  3 20:34:55 localhost kernel: [<ffffffff81370233>] ? sys_sendto+0x125/0x152
Jan  3 20:34:55 localhost kernel: [<ffffffff810fdb75>] ? __fput+0x1cb/0x1da
Jan  3 20:34:55 localhost kernel: [<ffffffff8110447d>] ? path_put+0x22/0x27
Jan  3 20:34:55 localhost kernel: [<ffffffff81095ed8>] ? audit_syscall_entry+0x11e/0x14a
Jan  3 20:34:55 localhost kernel: [<ffffffff81011cf2>] system_call_fastpath+0x16/0x1b
Jan  3 20:34:55 localhost kernel: ADDRCONF(NETDEV_UP): eth1: link is not ready
Jan  3 20:34:55 localhost NetworkManager: <info>  (eth1): preparing device.
Jan  3 20:34:55 localhost NetworkManager: <info>  (eth1): deactivating device (reason: 2).
Jan  3 20:34:55 localhost NetworkManager: Added default wired connection 'Auto eth1' for /sys/devices/pci0000:00/0000:00:1c.0/0000:02:00.0/net/eth1
Jan  3 20:34:55 localhost kernel: tg3: eth1: Link is down.
Jan  3 20:34:56 localhost kernel: tg3: eth1: Link is up at 100 Mbps, full duplex.
Comment 1 John Ruemker 2010-01-22 16:01:23 EST
Same problem here.  Same model and log messages, and the workaround fixes it for me.  Let me know if I can help with testing, debugging, or anything else.

Thanks,
-John
Comment 2 biAji 2010-03-15 01:51:48 EDT
This issue is duplicate to  https://bugzilla.redhat.com/show_bug.cgi?id=525966
Comment 3 John Levon 2010-03-15 12:59:40 EDT

*** This bug has been marked as a duplicate of bug 525966 ***