Bug 553389

Summary: preupgrade F11 - F12 does not run correctly
Product: [Fedora] Fedora Reporter: Eric Mesa <ericsbinaryworld>
Component: preupgradeAssignee: Richard Hughes <rhughes>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: 11CC: wwoods
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-06-28 11:36:22 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Eric Mesa 2010-01-07 14:16:26 EST
Description of problem:
Tried this a few times a couple nights ago with no luck.  Did a preupgrade and rebooted.  It says "starting installation" then *immediately* switches to "post-installation tasks" it reboots and I'm back in F11.  It looks to me as though it is not downloading the updates given that the whole thing takes about five minutes total. 

I also ran it in the GUI but via the commandline and the last part seemed a bit suspicious.  It said 500MB needed and then listed /usr as having about 13 GB and /boot as having .... I forget exactly how much, but it was more than was needed for the kernel.

My /boot directory has 244 MB.

I also tried the trick where you fill up /boot with garbage and have it download the installer upon reboot.  That also failed.  Although, this time it ran enough to where I could hit next and tell it to upgrade and update GRUB.  

It's hard to see what's going on because when it's done "installing" the upgrade it reboots.  But I switched to one of the virtual terminals (F3, I think) and it appears to be having problems finding sda1.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.run preupgrade
2.reboot
3.end up in F11
  
Actual results:
Does not run upgrade

Expected results:
upgrade should be run

Additional info:
-Good thing is that when it runs post-installation stuff it erases everything from /boot and I appear to be left with a nice, clean F11 install as if I hadn't done anything
-before running it after the first time was unsuccessful I ran yum update and updated everything
-before running it the last time I ran a yum clean all 
-again, I think a key problem is the fact that it appears not to be downloading ANYTHING other than the installer.img during the preupgrade.
Comment 1 Eric Mesa 2010-01-07 14:24:49 EST
One more set of facts I forgot to mention in additional info.

-this computer started with a fresh install of F10
-I used preupgrade successfully to go F10 -> F11
Comment 2 Bug Zapper 2010-04-28 07:40:34 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Bug Zapper 2010-06-28 11:36:22 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.