This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 554191

Summary: Segfault on URL syntax error [lxc]
Product: [Fedora] Fedora Reporter: Robin Green <greenrd>
Component: libvirtAssignee: Daniel Veillard <veillard>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 12CC: berrange, clalance, crobinso, itamar, jforbes, oron, veillard, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: libvirt-0.7.1-18.fc12 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-07-08 14:18:05 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Robin Green 2010-01-10 16:27:23 EST
Description of problem:
libirtd segfaults when given an LXC URL that has too few slashes in it.

Version-Release number of selected component (if applicable):
libvirt-0.7.5-1.fc13.i686

How reproducible:
Always

Steps to Reproduce:
1. libvirtd
2. virsh --connect lxc:// list
  
Actual results:
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xb55fcb70 (LWP 7199)]
0x080ac1c1 in lxcOpen (conn=0x8204418, auth=0x0, flags=0) at lxc/lxc_driver.c:129
129	        if (STRNEQ(conn->uri->path, "/")) {
(gdb) bt
#0  0x080ac1c1 in lxcOpen (conn=0x8204418, auth=0x0, flags=0) at lxc/lxc_driver.c:129
#1  0x009e5216 in do_open (name=<value optimized out>, auth=<value optimized out>, flags=<value optimized out>) at libvirt.c:1117
#2  0x08065e7a in remoteDispatchOpen (server=<value optimized out>, client=<value optimized out>, conn=<value optimized out>, hdr=<value optimized out>, 
    rerr=<value optimized out>, args=<value optimized out>, ret=<value optimized out>) at remote.c:161
#3  0x080677ba in remoteDispatchClientCall (server=<value optimized out>, client=<value optimized out>, msg=0xb754b008) at dispatch.c:506
#4  0x08067bf3 in remoteDispatchClientRequest (server=<value optimized out>, client=<value optimized out>, msg=0xb754b008) at dispatch.c:388
#5  0x0805a2a8 in qemudWorker (data=<value optimized out>) at libvirtd.c:1522
#6  0x0074fb65 in start_thread (arg=<value optimized out>) at pthread_create.c:297
#7  0x006761ce in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Expected results:
error message
Comment 1 Daniel Berrange 2010-02-11 10:02:16 EST
Fix posted upstream

http://www.redhat.com/archives/libvir-list/2010-February/msg00385.html
Comment 2 Bug Zapper 2010-03-15 09:48:55 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Cole Robinson 2010-05-10 16:39:23 EDT
*** Bug 581049 has been marked as a duplicate of this bug. ***
Comment 4 Cole Robinson 2010-05-18 12:54:04 EDT
This is fixed in rawhide and F13, we should backport to F12 though.
Comment 5 Fedora Update System 2010-06-17 12:55:30 EDT
libvirt-0.7.1-18.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/libvirt-0.7.1-18.fc12
Comment 6 Fedora Update System 2010-06-21 09:02:13 EDT
libvirt-0.7.1-18.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libvirt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/libvirt-0.7.1-18.fc12
Comment 7 Fedora Update System 2010-07-08 14:17:00 EDT
libvirt-0.7.1-18.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.