Bug 554230

Summary: No translated text replacement when <para> tag has attribute "revision"
Product: [Community] Publican Reporter: Richard Wilding <rwilding>
Component: publicanAssignee: Jeff Fearn <jfearn>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 1.6CC: jfearn, mmcallis, nb, publican-list, r.landmann
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 1.4-1.fc12 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-01-31 20:14:48 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
Sample of proposed change none

Description Richard Wilding 2010-01-10 20:41:57 EST
Problem occurs when building translations.
Translated text is not replacing en-US text when the <para> tag has a revision attribute.
Example: <para revision="1">

This is valid under the Docbook spec:
http://www.sagehill.net/docbookxsl/RevisionControl.html

Version-Release number of selected component (if applicable): Fedora 11


How reproducible: always
Comment 1 Jeff Fearn 2010-01-18 20:44:01 EST
Created attachment 385295 [details]
Sample of proposed change

Hi Richard, the current code sets the width to 60 and will be pushed out from there for individual lines greater than 60. Thus you will get a staggered layout if lines are variably above 60.

I'm thinking of changing this to make the default width 40, but if any line is greater than 36 it will change to maximum line with + 4.

This isn't full support for LineColumn, but it's something that I can get in the next version. Full support for LineColumn will take longer to implement.

Cheers, Jeff.
Comment 2 Jeff Fearn 2010-01-18 21:18:13 EST
oops, wrong bug obviously :(
Comment 3 Jeff Fearn 2010-01-19 21:10:16 EST
The text generated by the XML parser generates extra text if a tag contains attributes, this caused the string match to fail. Since the attribute content can not be stored in the PO file, and it probably wouldn't be useful for translation work flow anyway, I removed the attributes from the comparison string.

Note that the attributes will be present in the translated XML and thus will affect the XSLT operations as expected.
Comment 4 Fedora Update System 2010-01-28 21:05:24 EST
publican-1.4-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/publican-1.4-1.fc12
Comment 5 Fedora Update System 2010-01-28 21:06:42 EST
publican-1.4-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/publican-1.4-1.fc11
Comment 6 Fedora Update System 2010-01-31 20:13:31 EST
publican-1.4-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2010-01-31 20:21:53 EST
publican-1.4-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.