Bug 555899

Summary: Problem with ruby 1.8.6 and SiSU
Product: [Fedora] Fedora Reporter: Nathan Thomas <nathan>
Component: rubyAssignee: Jeroen van Meeuwen <vanmeeuwen+fedora>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 12CC: jeremy, mtasaka, nathan, tagoh, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-01-20 19:15:25 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Example SiSU markup file none

Description Nathan Thomas 2010-01-15 16:11:04 EST
Created attachment 384710 [details]
Example SiSU markup file

Description of problem: SiSU is an information structuring, publishing and search framework written in Ruby. I am able to compile SiSU from source in Fedora 12 with Ruby 1.8.6, but attempting to convert a marked up document to ODT format using SiSU produces an error. Using SiSU on the same system with Ruby 1.9.1 produces the desired result, suggesting that the cause is a bug with the 1.8.6 version.


Version-Release number of selected component (if applicable): Ruby 1.8.6, SiSU 0.70.5


How reproducible:


Steps to Reproduce:
1. Install SiSU from source (no other dependencies required apart from Ruby)
2. Attempt to convert the attached file 'sisu_test.sst' using the command 'sisu -o <file>'.
3. 
  
Actual results: Error message produced, no .odt file


Expected results: File 'opendocument.odt' produced in the folder '~/sisu_www', no error message.


Additional info: Version 1.9.1 of Ruby fixes problem
Comment 1 Jeroen van Meeuwen 2010-01-20 19:15:25 EST
I can't go around supporting stuff that is not in Fedora. That said, if there's a fix for it, I'd be willing to look at it.
Comment 2 Akira TAGOH 2010-01-20 21:52:12 EST
Since there are too much difference between 1.8.x and 1.9.x, the problem description is vague to determine if it's the ruby bug or the application bug. You can write the code working expectedly on 1.9 only. also Jeroen said we don't ship SiSU in Fedora, you should ask SiSU upstream first.

Hopes that help,