This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours

Bug 558863

Summary: RFE: Upgrade the swing-layout to version 1.0.4
Product: [Fedora] Fedora Reporter: Victor G. Vasilyev <victor.vasilyev>
Component: swing-layoutAssignee: Lubomir Rintel <lkundrak>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: lkundrak
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-02-21 12:21:56 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 541638    

Description Victor G. Vasilyev 2010-01-26 10:36:33 EST
Description of problem:

Since the swing-layout version 1.0.4 has been released, the NetBeans 6.8 [1] uses this latest version. The version 1.0.4 provides important changes for the getBaseline methods [2].

[1] https://fedoraproject.org/wiki/Features/NetBeans_6.8
[2] https://swing-layout.dev.java.net/source/browse/swing-layout/releaseNotes.txt?view=markup

Additional info:

To simplify this upgrade I've prepared new SRPM and completed scratch koji build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1945568

The swing-layout-1.0.4-1.fc13.src.rpm contains the upstream source swing-layout-1.0.4-src.zip downloaded from the swing-layout.dev.java.net site. Included spec file contains minor changes required only for changing the version.
Comment 1 Lubomir Rintel 2010-02-17 03:08:19 EST
Victor, sorry for the late response. I intended to pull the package now, but as I'm a bit late the scratch build already expired. Please reupload it.

That said, feel free to commit your changes without asking me at all if you wish (we have a VCS, I could back out your changes if I did not like them). You may have to apply for commit ACL in pkgdb if you aren't a provenpackager. If NetBeans has a big dependency chain in distribution in may be a good idea to apply for provenpackager group.

Thank you!
Comment 2 Victor G. Vasilyev 2010-02-17 06:51:09 EST
Successful scratch koji build
http://koji.fedoraproject.org/koji/taskinfo?taskID=1993057
Build Target: dist-f13-updates-candidate

I agree with you about VCS, so I've committed ACL against swing-layout package.
Thanks for hint about provenpackager group.
Comment 3 Lubomir Rintel 2010-02-17 07:03:11 EST
Thank you! I approved your ACL.
Comment 4 Victor G. Vasilyev 2010-02-17 08:35:42 EST
Lubomir,

I've committed the changes into the devel branch, tagged it with: swing-layout-1_0_4-1_fc14, and completed the build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1993233

You might complete the "post mortem" review for the changes, and approve it if all is OK.

BTW I trying to understand how to get the changes into F13 according to the new policies after implementing of the new technique "no frozen rawhide". Now, I have only obtained a first level of understanding, i.e. I understand nothing :-)
Comment 5 Lubomir Rintel 2010-02-17 09:01:17 EST
Victor, just merge the changes into F-13 branches and create an update in Bodhi. 

As far as I understand those will be pushed into F-13 automatically until RC stage, where they will be tagged manually or postponed to 0day updates.
Comment 6 Victor G. Vasilyev 2010-02-21 12:21:56 EST
Lubomir,

Thanks for the package updating in F13 branch.
I've completed sanity tests against the updated packages together with the NetBeans 6.8.
Seems all is OK, and we can close this Bug.

P.S. After the branching devel -> F13 I've not automatically got rights for committing in F13 branch.