Bug 55908

Summary: Anacanda Traceback error on installation
Product: [Retired] Red Hat Linux Reporter: Need Real Name <mj2099.geo>
Component: anacondaAssignee: Brent Fox <bfox>
Status: CLOSED NOTABUG QA Contact: Brock Organ <borgan>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.2   
Target Milestone: ---   
Target Release: ---   
Hardware: i586   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2001-11-11 17:49:15 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
anacanda Traceback Install error none

Description Need Real Name 2001-11-08 16:27:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt)

Description of problem:
an error occurs during installation, ref Traceback error.The installation 
stops and gives the option to print the error to a disk in text format. 
after that the installation stops. Unable to load second CD.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. attempted to re install the software from begining to end with same 
result.

	

Actual Results:  anacanda Trace back error occurs. Proceed to copy to .txt 
file

Expected Results:  I beleive I shoul be able to continue the remainder of 
the install and hopefully the second CD

Additional info:

The following is an excerp from the dump file:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 620, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/gui.py", line 350, in run
    self.icw.run (self.runres, configFileData)
  File "/usr/lib/anaconda/gui.py", line 778, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2608, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/anaconda/gui.py", line 497, in handleRenderCallback
    self.currentWindow.renderCallback()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 135, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 399, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 143, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 208, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 563, in doInstall
    problems = ts.run(0, ~rpm.RPMPROB_FILTER_DISKSPACE, cb.cb, 0)
  File "/usr/lib/anaconda/packages.py", line 225, in cb
    fn = self.method.getFilename(h, self.pkgTimer)
  File "/usr/lib/anaconda/image.py", line 88, in getFilename
    isys.umount("/mnt/source")
  File "/usr/lib/anaconda/isys.py", line 152, in umount
    rc = _isys.umount(what)
SystemError: (16, 'Device or resource busy')

Local variables in innermost frame:
what: /mnt/source
removeDir: 1

Comment 1 Need Real Name 2001-11-08 16:29:21 UTC
Created attachment 36881 [details]
anacanda Traceback Install error

Comment 2 Brent Fox 2001-11-08 16:54:01 UTC
I think you have a bad cd.  The kernel error messages say:

<4>hdd: irq timeout: status=0xd0 { Busy }
<4>hdd: ATAPI reset complete
<4>hdd: irq timeout: status=0xc0 { Busy }
<4>hdd: ATAPI reset complete
<4>hdd: irq timeout: status=0xc0 { Busy }
<4>end_request: I/O error, dev 16:40 (hdd), sector 993468
<4>hdd: cdrom_decode_status: status=0x51 { DriveReady SeekComplete Error }
<4>hdd: cdrom_decode_status: error=0x30


Which leads me to believe that the cdrom is damaged somehow.  This is a dupe of
bug #55693.

*** This bug has been marked as a duplicate of 55693 ***

Comment 3 Need Real Name 2001-11-08 19:16:40 UTC
If this is a bad CD-rom disc how can I get a replacement for just the one or 
does the whole package need to come back. I am unable to return it to the 
retail store since their return policy time has expired. Any information will 
be grately appreciated.

Comment 4 Brent Fox 2001-11-08 21:19:52 UTC
I see that your cdrom is device "hdd".  Yet it doesn't look like there is a
device "hdc".  Is the cdrom drive set to "Master" on the drive jumpers?  It
looks like it might be set to "Slave" on the secondary IDE bus and that there
might be no "Master" device.  This could be causing the trouble.

Comment 5 Need Real Name 2001-11-11 17:49:10 UTC
Thanks for pointing out the Master/Slave issue. After trying to adjust that 
CDRom drive and make it a Master ( failed miserably), I installed another one 
and it took as a Master and subsequently I was able to install 7.2 completely. 
Crisis contained. Thaks again.

Comment 6 Brent Fox 2001-11-13 20:32:46 UTC
Ok.  I'm glad things are working now.  Thanks for your report.