Bug 559682

Summary: [abrt] crash in compiz-0.8.2-21.fc12 @[AirplaneExtraPolygonTransformFunc]
Product: [Fedora] Fedora Reporter: Lawrence Graves <lgraves>
Component: compizAssignee: Adel Gadllah <adel.gadllah>
Status: CLOSED CANTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 12CC: adel.gadllah, campbecg, jeff.raber
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard: abrt_hash:9819c8e04df2a2b54d874c0369d5c9a7f7d00beb
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-04-23 05:35:19 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
File: backtrace none

Description Lawrence Graves 2010-01-28 13:27:21 EST
abrt 1.0.4 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: compiz --replace --sm-disable --ignore-desktop-hints ccp --loose-binding --indirect-rendering
component: compiz
executable: /usr/bin/compiz
kernel: 2.6.31.12-174.2.3.fc12.x86_64
package: compiz-0.8.2-21.fc12
rating: 4
reason: Process was terminated by signal 11 (Segmentation fault)
release: Fedora release 12 (Constantine)
Comment 1 Lawrence Graves 2010-01-28 13:27:23 EST
Created attachment 387403 [details]
File: backtrace
Comment 2 Chris Campbell 2010-02-07 22:40:28 EST
Thread 1 (Thread 2630):
#0  0x00007fbbc0de3688 in AirplaneExtraPolygonTransformFunc (p=0x36772e0)
    at airplane3d.c:822
        aep = 0x21
#1  0x00007fbbc0dec213 in polygonsDrawCustomGeometry (w=<value optimized out>)
    at polygon.c:1661
        newOpacityPolygon = <value optimized out>
        k = <value optimized out>
        fadeBackAndSides = <value optimized out>
        attrib = {opacity = 4964, brightness = 49805, saturation = 65535, 
          nTexture = 0, function = {0 <repeats 16 times>}, nFunction = 0, 
          nParam = 0}
        p = 0x36772e0
        newOpacityPolygon2 = <value optimized out>
        c = 0x368e530
        nFrontVerticesTilThisPoly = <value optimized out>
        nNewSides = <value optimized out>
        i = <value optimized out>
        j = 0
        s = 0x230a050
        ad = 0x2b49940
        aw = 0x35e6ce0
        pset = 0x35af1d0
        lastClip = 0
        forwardProgress = <value optimized out>
        normalArrayWas = <value optimized out>
        clipPlane0 = {1, 0, 0, 13.0999755859375}
        clipPlane1 = {0, 1, 0, 13.100006103515625}
        clipPlane2 = {-1, 0, 0, 297.0999755859375}
        clipPlane3 = {0, -1, 0, 13.100006103515625}
        oldColor = {0.999969482, 0.999969482, 0.999969482, 1}
        prevActiveTexture = 33984
        saturationFull = <value optimized out>
        opacity = 0.0757575035
        newOpacity = <value optimized out>
        fadePassedBy = <value optimized out>
        skewMat = {1, 0, 0, 0, 0, 1, 0, 0, 1104, 621, 1, 0, 0, 0, 0, 1}
        pass = <value optimized out>
#2  0x0000000000425357 in enableFragmentOperationsAndDrawGeometry (w=
    0x36752e0, texture=0x35ce620, attrib=0x7fffe4367160, 
    mask=<value optimized out>) at paint.c:1122
        color = 65533
        s = <value optimized out>
#3  drawWindowTexture (w=0x36752e0, texture=0x35ce620, attrib=0x7fffe4367160, 
    mask=<value optimized out>) at paint.c:1176
        filter = 1
#4  0x00007fbbc26c768c in videoDrawWindowTexture (w=0x36752e0, texture=
    0x35ce620, attrib=<value optimized out>, mask=<value optimized out>)
    at video.c:487
        s = 0x230a050
        vs = 0x2509860




-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Chris Campbell 2010-02-11 14:45:35 EST

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Jeff Raber 2010-04-23 05:35:19 EDT
Thanks for the report. We are sorry that we cannot help you with your problem, but we are not able to support binary-only drivers. If you would be able to reproduce this issue using only open source software, please, reopen this bug with the additional information, but in meantime I have no choice than to close this bug as CANTFIX (because we really cannot fix it).

The open source 'nouveau' driver (in package xorg-x11-drv-nouveau) is the recommended alternative for users of Nvidia graphic chips.  It is used by default in Fedora 11 and later if you remove any customization that explicitly set the video driver.  The older "nv" driver may be needed in some cases.  It is also available in older Fedora releases.  Install the packages xorg-x11-drv-nouveau or xorg-x11-drv-nv and override the X server's default choice if necessary.  See https://fedoraproject.org/wiki/Features/NouveauAsDefault for more information.

If you used a non-packaged version of the driver from the Nvidia website please clean your system from additional libraries and software it installed. For users who are experiencing problems installing, configuring, or using the unsupported 3rd party proprietary "nvidia" video driver, Nvidia provides indirect customer support via an online web based support forum.  Nvidia monitors these web forums for commonly reported problems and passes them on to Nvidia engineers for investigation.  Once they've isolated a particular problem, it is often fixed in a future video driver update.

The NVNews Nvidia Linux driver forum is located at:

	http://www.nvnews.net/vbulletin/forumdisplay.php?s=&forumid=14

Once you have reported this issue in the Nvidia web forums, others who may have experienced the particular problem may be able to assist.  If there is a real bug occurring, Nvidia will be able to determine this, and will likely resolve the issue in a future driver update for the operating system releases that they officially support.

While we do not support the proprietary nvidia driver, users requiring technical support may also find the various X.Org, XFree86, and Red Hat/Fedora mailing lists helpful in finding assistance:

X.Org mailing lists:
	http://www.freedesktop.org/XOrg/XorgMailingLists

XFree86 mailing lists:
	http://www.xfree86.org/sos/lists.html

Red Hat/Fedora mailing lists:
	https://listman.redhat.com/mailman/listinfo

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers