Bug 560790

Summary: Unable to restore a rogue game from a saved-game file
Product: [Fedora] Fedora Reporter: Robert Bogomip <bob.bogo>
Component: rogueAssignee: Wart <wart>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 12CC: wart
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: rogue-5.4.5-6.fc12 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-05-15 20:32:11 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Robert Bogomip 2010-02-01 20:40:39 UTC
Description of problem:
Unable to restore a game from a saved-game file

Version-Release number of selected component (if applicable):
rogue-5.4.5-5.fc12.x86_64

How reproducible:
Every time for me

Steps to Reproduce:
1. Start rogue
  $ rogue
2. Press 'S' (game save)
3. Press 'Y' (accept the default of ~/rogue.save)
4. Restart rogue, this time giving it the save file
  $ rogue /home/<user>/rogue.save
  
Actual results:
"Segmentation fault (core dumped)" 


Expected results:
Game continues from where you saved it.

Additional info:

Comment 1 Wart 2010-04-25 01:14:22 UTC
I was able to reproduce this finally.  It looks like there is a problem loading the staff/wand information from the save file.  At the moment it isn't clear if it's a bug in the reading or writing code.

Comment 2 Fedora Update System 2010-04-25 15:47:29 UTC
rogue-5.4.5-6.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/rogue-5.4.5-6.fc13

Comment 3 Fedora Update System 2010-04-25 15:47:33 UTC
rogue-5.4.5-6.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/rogue-5.4.5-6.fc12

Comment 4 Fedora Update System 2010-04-27 02:28:31 UTC
rogue-5.4.5-6.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rogue'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/rogue-5.4.5-6.fc12

Comment 5 Fedora Update System 2010-04-27 02:30:42 UTC
rogue-5.4.5-6.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rogue'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/rogue-5.4.5-6.fc13

Comment 6 Robert Bogomip 2010-04-29 08:54:29 UTC
rogue-5.4.5-6.fc12.x86_64 works for me. Thanks :-)

Comment 7 Fedora Update System 2010-05-15 20:32:06 UTC
rogue-5.4.5-6.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2010-05-15 20:40:25 UTC
rogue-5.4.5-6.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.