Bug 561494

Summary: SELinux is preventing /usr/bin/qemu-kvm "read write" access on 012.
Product: [Fedora] Fedora Reporter: George Iosif <giosif>
Component: libvirtAssignee: Daniel Veillard <veillard>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 12CC: berrange, clalance, crobinso, dwalsh, itamar, jforbes, mgrepl, veillard, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard: setroubleshoot_trace_hash:f98a11c2b3ad6f2c34bc104d28225ed3fd5823eb07da788b9b1ce26b977c088f
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-02-03 14:10:18 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description George Iosif 2010-02-03 14:02:18 EST
Summary:

SELinux is preventing /usr/bin/qemu-kvm "read write" access on 012.

Detailed Description:

SELinux denied access requested by qemu-kvm. It is not expected that this access
is required by qemu-kvm and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:svirt_t:s0:c1,c865
Target Context                system_u:object_r:usb_device_t:s0
Target Objects                012 [ chr_file ]
Source                        qemu-kvm
Source Path                   /usr/bin/qemu-kvm
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           qemu-system-x86-0.11.0-12.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-78.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.31.12-174.2.3.fc12.x86_64 #1 SMP Mon Jan 18
                              19:52:07 UTC 2010 x86_64 x86_64
Alert Count                   1
First Seen                    Wed 03 Feb 2010 18:56:32 GMT
Last Seen                     Wed 03 Feb 2010 18:56:32 GMT
Local ID                      36754208-bca0-4336-b1a0-2f52dadfd849
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1265223392.919:157): avc:  denied  { read write } for  pid=24365 comm="qemu-kvm" name="012" dev=tmpfs ino=2568037 scontext=system_u:system_r:svirt_t:s0:c1,c865 tcontext=system_u:object_r:usb_device_t:s0 tclass=chr_file

node=(removed) type=SYSCALL msg=audit(1265223392.919:157): arch=c000003e syscall=2 success=no exit=-13 a0=7fffdba267d0 a1=802 a2=7fffdba267e4 a3=fffffff4 items=0 ppid=1 pid=24365 auid=500 uid=107 gid=107 euid=107 suid=107 fsuid=107 egid=107 sgid=107 fsgid=107 tty=(none) ses=4 comm="qemu-kvm" exe="/usr/bin/qemu-kvm" subj=system_u:system_r:svirt_t:s0:c1,c865 key=(null)



Hash String generated from  selinux-policy-3.6.32-78.fc12,catchall,qemu-kvm,svirt_t,usb_device_t,chr_file,read,write
audit2allow suggests:

#============= svirt_t ==============
allow svirt_t usb_device_t:chr_file { read write };
Comment 1 Daniel Walsh 2010-02-03 14:10:18 EST

*** This bug has been marked as a duplicate of bug 550951 ***