This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 562686

Summary: scp should have a -u option
Product: [Fedora] Fedora Reporter: JW <ohtmvyyn>
Component: opensshAssignee: Jan F. Chadima <jchadima>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 12CC: jchadima, mgrepl, tmraz
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-02-08 02:29:46 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description JW 2010-02-07 19:32:44 EST
Description of problem:
scp should have a -u option (update) like cp does.

Version-Release number of selected component (if applicable):
openssh-5.2p1-31

How reproducible:
Always

Steps to Reproduce:
1. man scp
2. /-u /
  
Actual results:
2. Pattern not found

Expected results:
2. -u. --update copy  only  when  the  SOURCE file is newer than the destination file or when the destination file is missing

Additional info:
In this day and age it is something of an anachronism that we still have cp, rcp, scp all as separate applications.  The copying of a file from one place to another should be relatively seamless, and the one 'cp' should be able to do it all.  If 'scp' functionality was incorporate into 'cp', or if 'scp' had a -u option then we could probably get rid of stop-gap programs like 'rsync'.

I would prefer to see a better 'cp' which supported network/intra-host copying. It would have an optional '-x' flag to control encryption, which would default to on for network copying.

Maybe this might also be a coreutils bug?

But in any case since scp will be around for many more years, it should have a simple -u option.
Comment 1 Tomas Mraz 2010-02-08 02:29:46 EST
OpenSSH upstream declared that they will not add any new features to scp and they declared it a legacy application.
We will not diverge from upstream here.
If you have any special arguments which could convince upstream to implement your proposal, you can try to report the feature request here to the upstream bugzilla:
http://bugzilla.mindrot.org/