Bug 564667

Summary: FTBFS ario-1.1-8.fc12: ImplicitDSOLinking
Product: [Fedora] Fedora Reporter: FTBFS <ftbfs>
Component: arioAssignee: John F <johnhford>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: rawhideCC: johnhford
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
URL: http://linux.dell.com/files/fedora/FixBuildRequires/mock-results/
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-02-17 13:36:21 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 564245    
Attachments:
Description Flags
root.log
none
build.log
none
mock.log
none
root.log
none
build.log
none
mock.log none

Description FTBFS 2010-02-13 11:32:45 EST
ario-1.1-8.fc12.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 11:32:48 EST
Created attachment 391040 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 11:32:49 EST
Created attachment 391041 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 11:32:51 EST
Created attachment 391042 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 11:32:53 EST
Created attachment 391043 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 11:32:55 EST
Created attachment 391044 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 11:32:56 EST
Created attachment 391045 [details]
mock.log

mock.log for x86_64
Comment 7 Adam Jackson 2010-02-17 13:36:21 EST
Fixed in rawhide.