Bug 564883

Summary: FTBFS surf-0.3-2.fc13: ImplicitDSOLinking
Product: [Fedora] Fedora Reporter: FTBFS <ftbfs>
Component: surfAssignee: Simon <cassmodiah>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: 13CC: cassmodiah, redhat-bugzilla
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
URL: http://linux.dell.com/files/fedora/FixBuildRequires/mock-results/
Whiteboard:
Fixed In Version: surf-0.3-3.fc13 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-03-25 18:25:18 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 564245    
Attachments:
Description Flags
root.log
none
build.log
none
mock.log
none
root.log
none
build.log
none
mock.log
none
surf-0.3-libX11.patch none

Description FTBFS 2010-02-13 12:12:52 EST
surf-0.3-2.fc13.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 12:12:56 EST
Created attachment 392281 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 12:12:57 EST
Created attachment 392282 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 12:12:58 EST
Created attachment 392283 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 12:13:00 EST
Created attachment 392284 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 12:13:01 EST
Created attachment 392285 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 12:13:03 EST
Created attachment 392286 [details]
mock.log

mock.log for x86_64
Comment 7 Bug Zapper 2010-03-15 10:45:52 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Robert Scheck 2010-03-23 15:36:12 EDT
Created attachment 402128 [details]
surf-0.3-libX11.patch

From my point of view, this patch solves the issue.
Comment 9 Fedora Update System 2010-03-24 16:55:10 EDT
surf-0.3-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/surf-0.3-3.fc13
Comment 10 Fedora Update System 2010-03-25 18:25:14 EDT
surf-0.3-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.