Bug 564921

Summary: FTBFS certmonger-0.17-2.fc13: ImplicitDSOLinking
Product: [Fedora] Fedora Reporter: FTBFS <ftbfs>
Component: certmongerAssignee: Nalin Dahyabhai <nalin>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: 13CC: bruno, nalin
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
URL: http://linux.dell.com/files/fedora/FixBuildRequires/mock-results/
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-03-27 16:56:30 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On: 565577    
Bug Blocks: 564245    
Attachments:
Description Flags
root.log
none
build.log
none
mock.log
none
root.log
none
build.log
none
mock.log none

Description FTBFS 2010-02-13 12:19:37 EST
certmonger-0.17-2.fc13.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 12:19:40 EST
Created attachment 392487 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 12:19:41 EST
Created attachment 392488 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 12:19:42 EST
Created attachment 392489 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 12:19:43 EST
Created attachment 392490 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 12:19:44 EST
Created attachment 392491 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 12:19:46 EST
Created attachment 392492 [details]
mock.log

mock.log for x86_64
Comment 7 Nalin Dahyabhai 2010-02-15 12:02:42 EST
Added a workaround to 0.18-1, but leaving this one open until bug #565577 is worked out.
Comment 8 Bug Zapper 2010-03-15 10:47:52 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Bruno Wolff III 2010-03-27 16:56:30 EDT
Since bug #565577 is closed now, it seems safe to close this one as well.
Thanks for fixing things.