Bug 564929

Summary: FTBFS xlockmore-5.28-1.fc12: ImplicitDSOLinking
Product: [Fedora] Fedora Reporter: FTBFS <ftbfs>
Component: xlockmoreAssignee: Adrian Reber <adrian>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: 13CC: adrian, jan.klepek
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
URL: http://linux.dell.com/files/fedora/FixBuildRequires/mock-results/
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-05-08 06:46:14 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 564245, 583276    
Attachments:
Description Flags
root.log
none
build.log
none
mock.log
none
root.log
none
build.log
none
mock.log none

Description FTBFS 2010-02-13 12:21:02 EST
xlockmore-5.28-1.fc12.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 12:21:05 EST
Created attachment 392532 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 12:21:06 EST
Created attachment 392533 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 12:21:08 EST
Created attachment 392534 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 12:21:10 EST
Created attachment 392535 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 12:21:11 EST
Created attachment 392536 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 12:21:12 EST
Created attachment 392537 [details]
mock.log

mock.log for x86_64
Comment 7 Bug Zapper 2010-03-15 10:48:17 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Jan Klepek 2010-05-04 16:18:28 EDT
Hi Adrian,

Any progress with this bug?
Comment 9 Adrian Reber 2010-05-08 06:46:14 EDT
Fixed in rawhide.