Bug 564958

Summary: FTBFS grisbi-0.5.9-10.fc12: ImplicitDSOLinking
Product: [Fedora] Fedora Reporter: FTBFS <ftbfs>
Component: grisbiAssignee: Aurelien Bompard <gauret>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: 13CC: gauret, jan.klepek
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
URL: http://linux.dell.com/files/fedora/FixBuildRequires/mock-results/
Whiteboard:
Fixed In Version: grisbi-0.5.9-11.fc13 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-05-06 03:00:22 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 564245, 583276    
Attachments:
Description Flags
root.log
none
build.log
none
mock.log
none
root.log
none
build.log
none
mock.log none

Description FTBFS 2010-02-13 12:26:31 EST
grisbi-0.5.9-10.fc12.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 12:26:34 EST
Created attachment 392703 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 12:26:37 EST
Created attachment 392704 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 12:26:38 EST
Created attachment 392705 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 12:26:39 EST
Created attachment 392706 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 12:26:42 EST
Created attachment 392707 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 12:26:43 EST
Created attachment 392708 [details]
mock.log

mock.log for x86_64
Comment 7 Bug Zapper 2010-03-15 10:49:48 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Jan Klepek 2010-05-04 16:20:04 EDT
Hi Aurelien,

Any progress with this bug?
Comment 9 Aurelien Bompard 2010-05-05 02:13:25 EDT
No, but it slipped under my radar. I'll try and find time to work on it asap.
Comment 10 Fedora Update System 2010-05-06 00:39:17 EDT
grisbi-0.5.9-11.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/grisbi-0.5.9-11.fc13
Comment 11 Fedora Update System 2010-05-06 03:00:18 EDT
grisbi-0.5.9-11.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.