Bug 564967

Summary: FTBFS ssmtp-2.61-11.10.fc12: ImplicitDSOLinking
Product: [Fedora] Fedora Reporter: FTBFS <ftbfs>
Component: ssmtpAssignee: manuel wolfshant <wolfy>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: rawhideCC: wolfy
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
URL: http://linux.dell.com/files/fedora/FixBuildRequires/mock-results/
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-02-16 17:37:15 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 564245    
Attachments:
Description Flags
root.log
none
build.log
none
mock.log
none
root.log
none
build.log
none
mock.log none

Description FTBFS 2010-02-13 12:28:16 EST
ssmtp-2.61-11.10.fc12.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 12:28:19 EST
Created attachment 392752 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 12:28:21 EST
Created attachment 392753 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 12:28:22 EST
Created attachment 392754 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 12:28:24 EST
Created attachment 392755 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 12:28:25 EST
Created attachment 392756 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 12:28:26 EST
Created attachment 392757 [details]
mock.log

mock.log for x86_64
Comment 7 manuel wolfshant 2010-02-16 17:37:15 EST
fixed in ssmtp-2.61-12: http://koji.fedoraproject.org/koji/taskinfo?taskID=1992140