Bug 565101

Summary: FTBFS xsd-3.2.0-7.fc13: ImplicitDSOLinking
Product: [Fedora] Fedora Reporter: FTBFS <ftbfs>
Component: xsdAssignee: Antti Andreimann <antti.andreimann>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: 13CC: antti.andreimann, bruno
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
URL: http://linux.dell.com/files/fedora/FixBuildRequires/mock-results/
Whiteboard:
Fixed In Version: xsd-3.3.0-1.fc13 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-07-16 14:49:24 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 564245, 583278    
Attachments:
Description Flags
root.log
none
build.log
none
mock.log
none
root.log
none
build.log
none
mock.log
none
Spec file patch
none
Build system patch none

Description FTBFS 2010-02-13 12:54:20 EST
xsd-3.2.0-7.fc13.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 12:54:23 EST
Created attachment 393524 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 12:54:24 EST
Created attachment 393525 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 12:54:25 EST
Created attachment 393526 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 12:54:27 EST
Created attachment 393527 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 12:54:28 EST
Created attachment 393528 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 12:54:29 EST
Created attachment 393529 [details]
mock.log

mock.log for x86_64
Comment 7 Bug Zapper 2010-03-15 10:56:26 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Bruno Wolff III 2010-05-02 12:00:42 EDT
Created attachment 410816 [details]
Spec file patch

The problem seems to be that libboost_filesystem can call things in libboost_system and that this dependency isn't defined by boost. (I am not sure if that is an error or just the way things work.)
I am attaching a spec file patch and a build patch that add in this dependency to the build system used by xsd. Even though libboost_filesystem seems to be in the build system for a few of the bundled parts of xsd, changing it in just the main one seems to work.
I put my name on the spec file change log, but feel free to do whatever you want with that.
I only tested the build, but I am not expecting the change to introduce any regressions.
Comment 9 Bruno Wolff III 2010-05-02 12:01:26 EDT
Created attachment 410817 [details]
Build system patch
Comment 10 Fedora Update System 2010-06-20 11:32:41 EDT
xsd-3.3.0-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/xsd-3.3.0-1.fc13
Comment 11 Fedora Update System 2010-06-21 17:34:33 EDT
xsd-3.3.0-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xsd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/xsd-3.3.0-1.fc13
Comment 12 Fedora Update System 2010-07-16 14:49:18 EDT
xsd-3.3.0-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.