Bug 565110

Summary: FTBFS libgtop2-2.28.0-1.fc12: ImplicitDSOLinking
Product: [Fedora] Fedora Reporter: FTBFS <ftbfs>
Component: libgtop2Assignee: Søren Sandmann Pedersen <sandmann>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: rawhideCC: kem, mclasen, sandmann
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
URL: http://linux.dell.com/files/fedora/FixBuildRequires/mock-results/
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-02-26 22:39:41 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 564245    
Attachments:
Description Flags
root.log
none
build.log
none
mock.log
none
root.log
none
build.log
none
mock.log none

Description FTBFS 2010-02-13 12:56:18 EST
libgtop2-2.28.0-1.fc12.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 12:56:21 EST
Created attachment 393578 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 12:56:26 EST
Created attachment 393579 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 12:56:27 EST
Created attachment 393580 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 12:56:28 EST
Created attachment 393581 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 12:56:29 EST
Created attachment 393582 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 12:56:30 EST
Created attachment 393583 [details]
mock.log

mock.log for x86_64
Comment 7 Matthias Clasen 2010-02-26 22:39:41 EST
fixes in libgtop2-2.28.0-2.fc13