Bug 565124

Summary: FTBFS quota-3.17-8.fc13: ImplicitDSOLinking
Product: [Fedora] Fedora Reporter: FTBFS <ftbfs>
Component: quotaAssignee: Daniel Novotny <dnovotny>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: rawhideCC: dnovotny, ovasik
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
URL: http://linux.dell.com/files/fedora/FixBuildRequires/mock-results/
Whiteboard:
Fixed In Version: quota-3.17-9.fc13 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-02-23 07:16:53 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 564245    
Attachments:
Description Flags
root.log
none
build.log
none
mock.log
none
root.log
none
build.log
none
mock.log none

Description FTBFS 2010-02-13 12:58:55 EST
quota-3.17-8.fc13.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 12:58:58 EST
Created attachment 393662 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 12:59:00 EST
Created attachment 393663 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 12:59:01 EST
Created attachment 393664 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 12:59:02 EST
Created attachment 393665 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 12:59:04 EST
Created attachment 393666 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 12:59:05 EST
Created attachment 393667 [details]
mock.log

mock.log for x86_64
Comment 7 Daniel Novotny 2010-02-23 07:16:53 EST
fixed in rawhide: quota-3.17-9.fc14

built for f13 and requested an F13 tag:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2008289
https://fedorahosted.org/rel-eng/ticket/3436
Comment 8 Fedora Update System 2010-02-23 08:54:34 EST
quota-3.17-9.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/quota-3.17-9.fc13
Comment 9 Fedora Update System 2010-02-23 11:06:29 EST
quota-3.17-9.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.