Bug 565162

Summary: FTBFS ember-0.5.6-4.fc13: ImplicitDSOLinking
Product: [Fedora] Fedora Reporter: FTBFS <ftbfs>
Component: emberAssignee: Alexey Torkhov <atorkhov>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: 13CC: atorkhov, michel, wart
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
URL: http://linux.dell.com/files/fedora/FixBuildRequires/mock-results/
Fixed In Version: ember-0.5.6-5.fc13 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-07-13 03:31:18 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 564245, 583278    
Description Flags
Patch acinclude.m4 to explicitly link against -lX11 when linking against -lGL none

Description FTBFS 2010-02-13 13:06:23 EST
ember-0.5.6-4.fc13.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 13:06:27 EST
Created attachment 393887 [details]

root.log for i386
Comment 2 FTBFS 2010-02-13 13:06:30 EST
Created attachment 393888 [details]

build.log for i386
Comment 3 FTBFS 2010-02-13 13:06:32 EST
Created attachment 393889 [details]

mock.log for i386
Comment 4 FTBFS 2010-02-13 13:06:34 EST
Created attachment 393890 [details]

root.log for x86_64
Comment 5 FTBFS 2010-02-13 13:06:37 EST
Created attachment 393891 [details]

build.log for x86_64
Comment 6 FTBFS 2010-02-13 13:06:39 EST
Created attachment 393892 [details]

mock.log for x86_64
Comment 7 Bug Zapper 2010-03-15 10:58:40 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
Comment 8 Michel Alexandre Salim 2010-07-04 10:16:28 EDT
Created attachment 429378 [details]
Patch acinclude.m4 to explicitly link against -lX11 when linking against -lGL

Package owners, please send the attached fix upstream, and explain our new policy banning implicit DSO linking.

For the Rawhide and F-13 build, I'm patching the configure script directly so that ember can be built without pulling in autoconf and automake.
Comment 9 Michel Alexandre Salim 2010-07-04 10:30:14 EDT
Looks like 0.5.7 no longer link against libGL, so it might not be necessary to file the autotools patch upstream. Please update our Fedora packaging to 0.5.7, though -- I'll set up automatic version monitoring for it.
Comment 10 Michel Alexandre Salim 2010-07-04 10:36:06 EDT
*** Bug 599841 has been marked as a duplicate of this bug. ***
Comment 11 Fedora Update System 2010-07-04 10:53:46 EDT
ember-0.5.6-5.fc13 has been submitted as an update for Fedora 13.
Comment 12 Fedora Update System 2010-07-06 13:25:57 EDT
ember-0.5.6-5.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ember'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/ember-0.5.6-5.fc13
Comment 13 Fedora Update System 2010-07-13 03:31:13 EDT
ember-0.5.6-5.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.