Bug 565184

Summary: FTBFS warzone2100-2.3-0.2.beta9.fc13: ImplicitDSOLinking
Product: [Fedora] Fedora Reporter: FTBFS <ftbfs>
Component: warzone2100Assignee: Karol Trzcionka <karlikt>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: 13CC: bruno, karlikt, matt_domsch
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
URL: http://linux.dell.com/files/fedora/FixBuildRequires/mock-results/
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-06-03 18:30:41 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 564245, 583278    
Attachments:
Description Flags
root.log
none
build.log
none
mock.log
none
root.log
none
build.log
none
mock.log none

Description FTBFS 2010-02-13 13:10:33 EST
warzone2100-2.3-0.2.beta9.fc13.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 13:10:36 EST
Created attachment 394013 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 13:10:37 EST
Created attachment 394014 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 13:10:39 EST
Created attachment 394015 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 13:10:41 EST
Created attachment 394016 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 13:10:42 EST
Created attachment 394017 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 13:10:43 EST
Created attachment 394018 [details]
mock.log

mock.log for x86_64
Comment 7 Bug Zapper 2010-03-15 10:59:48 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Bruno Wolff III 2010-04-28 17:25:02 EDT
There has been a successful build recently, but it's not in the release yet.
Comment 9 Matt Domsch 2010-06-03 18:30:41 EDT
warzone2100-2.3.0-1.fc14.src.rpm
builds in rawhide.