Bug 567559

Summary: Only white images by PPM export
Product: [Fedora] Fedora Reporter: Tim Niemueller <tim>
Component: gourceAssignee: Siddhesh Poyarekar <spoyarek>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 12CC: mnewsome, spoyarek
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: gource-0.24-2.fc12 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-02-28 13:10:50 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Tim Niemueller 2010-02-23 09:33:18 UTC
Description of problem:
There seems to be a problem with PPM generation that causes PPMs contain only white images. I have only checked this on x86_64 atm, maybe you can check on i686? Have you tried generating videos and did it work for you? On the screen it's working as expected.

The problem has been reported upstream at http://code.google.com/p/gource/issues/detail?id=46

Version-Release number of selected component (if applicable):
0.24.x86_64

How reproducible:
Always

Steps to Reproduce:
1. ./gource -s 0.2 $GITDIR --stop-position 0.01 --output-framerate 30 
--output-ppm-stream stream.ppm
2. Open stream.ppm in file reader or image viewer and see only
invalid/empty frames.

  
Actual results:
White frames

Expected results:
Frames with same content produced on the screen.

Comment 1 Siddhesh Poyarekar 2010-02-23 12:17:31 UTC
I'm not able to reproduce this on my rawhide box. May have something to do with the graphics card or xorg/mesa-gl. To eliminate the latter, would it be possible to test with xorg from rawhide?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 2 Siddhesh Poyarekar 2010-02-27 15:35:47 UTC
Could you please confirm if the patch in the upstream bug report works correctly?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 3 Tim Niemueller 2010-02-27 20:04:41 UTC
Yes, the patch works just fine!

Comment 4 Fedora Update System 2010-02-28 12:56:39 UTC
gource-0.24-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/gource-0.24-2.fc13

Comment 5 Fedora Update System 2010-02-28 12:58:48 UTC
gource-0.24-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/gource-0.24-2.fc12

Comment 6 Siddhesh Poyarekar 2010-02-28 13:10:50 UTC
Patch from upstream bug report comment 13 included in gource-0.24-2 based on confirmation in comment 3 here. Closing as fixed. Thank you for reporting this bug.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 7 Fedora Update System 2010-03-03 01:49:43 UTC
gource-0.24-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2010-03-04 00:23:04 UTC
gource-0.24-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.