Bug 568592

Summary: epdfview does not load current page when reload button is used
Product: [Fedora] Fedora Reporter: Ranjan Maitra <itsme_410>
Component: epdfviewAssignee: Michal Schmidt <mschmidt>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 12CC: mschmidt
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: epdfview-0.1.7-5.20100302svn.fc12 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-03-10 06:56:28 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 568973    

Description Ranjan Maitra 2010-02-26 05:36:08 UTC
Description of problem:

The epdfview executable does not load current page when the reload button is used on an open file.

Version-Release number of selected component (if applicable):

0.1.7.7

How reproducible:

everytime

Steps to Reproduce:
1. open a document using epdfview
2. go to page 2 or 3 or 4 or any page other than page 1.
3. Click "reload" or use "ctrl-r"
  
Actual results:

the document goes back to the first page. for a longer document, it is irritating to have to go rummage through the old page over and over again.

Expected results:

the document should reload to the current page, as other programs such as evince and xpdf do.

Additional info:

This is a known bug in epdfview with a fix provided here:

http://trac.emma-soft.com/epdfview/changeset/342

epdfview/emmasoft will eventually release it in an update, but going by how slowly they release updates (sometimes, not for two years, and it is already one year since 0.1.7, it makes sense to correct the patch so that users may be able to use this lightweight pdf file reader more effectively.

Comment 1 Michal Schmidt 2010-02-26 08:56:08 UTC
With the first random PDF I tried it worked fine, but with another one I can reproduce the bug. I agree the upstream intervals between releases are a bit too long. Looking at the upstream svn log I saw that a few more bugfixes I'd like to have, so I'm going to just update to the latest version from svn trunk to pick them all.

Building it in Koji now for devel, F-13 and F-12.

Comment 2 Fedora Update System 2010-02-26 09:06:20 UTC
epdfview-0.1.7-3.20100226svn.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/epdfview-0.1.7-3.20100226svn.fc12

Comment 3 Ranjan Maitra 2010-02-26 16:34:25 UTC
Thanks very much! I have verified that these new rpms work as advertised both for i686 and x86_64. Thanks very much again!! This sort of response is what makes Fedora so different and special!!

Comment 4 Fedora Update System 2010-02-27 03:46:57 UTC
epdfview-0.1.7-3.20100226svn.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update epdfview'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-3087

Comment 5 Fedora Update System 2010-03-01 09:04:45 UTC
epdfview-0.1.7-4.20100226svn.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/F12/FEDORA-2010-3087

Comment 6 Fedora Update System 2010-03-02 00:56:00 UTC
epdfview-0.1.7-4.20100226svn.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update epdfview'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-3087

Comment 7 Fedora Update System 2010-03-02 09:49:32 UTC
epdfview-0.1.7-5.20100302svn.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/F12/FEDORA-2010-3087

Comment 8 Fedora Update System 2010-03-03 02:02:46 UTC
epdfview-0.1.7-5.20100302svn.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update epdfview'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-3087

Comment 9 Ranjan Maitra 2010-03-03 13:09:03 UTC
works as advertised. all bugs and quirks listed here have been fixed.

Comment 10 Fedora Update System 2010-03-10 06:56:17 UTC
epdfview-0.1.7-5.20100302svn.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.