Bug 569317

Summary: -l no longer works
Product: [Fedora] Fedora Reporter: Jan Kratochvil <jan.kratochvil>
Component: acpitoolAssignee: Steven M. Parrish <smparrish>
Status: CLOSED UPSTREAM QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 12CC: pertusus, smparrish
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-03-14 03:30:29 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Jan Kratochvil 2010-03-01 04:57:47 EST
Description of problem:
I was using "acpitool -l 7" successfully before but it no longer works - expecting due to the current kernel.
Using Lenovo Thinkpad T60, BIOS 79ETE5WW (2.25).

Version-Release number of selected component (if applicable):
acpitool-0.5.1-1.fc12.x86_64
kernel-2.6.32.8-58.fc12.x86_64

How reproducible:
Always.

Steps to Reproduce:
acpitool -l 7

Actual results:
Could not open file: /proc/acpi/ibm/brightness for writing.

Expected results:
Brightness set.

Additional info:
# tail -n999 /proc/acpi/video/*/*/brightness
==> /proc/acpi/video/VID1/CRT0/brightness <==
<not supported>

==> /proc/acpi/video/VID1/DVI0/brightness <==
<not supported>

==> /proc/acpi/video/VID1/LCD0/brightness <==
levels:  30 40 50 60 70 80 90 100
current: 100
# echo 100 >/proc/acpi/video/VID1/LCD0/brightness
works fine
Comment 1 Steven M. Parrish 2010-03-13 22:00:51 EST
This is something that needs to be reported to the upstream developers.

Please report it at http://freeunix.dyndns.org:8000/site2/acpitool.shtml

Thanks
Comment 2 Jan Kratochvil 2010-03-14 03:30:29 EDT
Posted as:
https://sourceforge.net/tracker/?func=detail&aid=2970132&group_id=111358&atid=659017
(but some other two bugs are open there since 2007)