Bug 575979

Summary: qemu m68k fails to run
Product: [Fedora] Fedora Reporter: igor.redhat <igor.redhat>
Component: qemuAssignee: Justin M. Forbes <jforbes>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 12CC: amit.shah, berrange, dwmw2, ehabkost, gcosta, itamar, jaswinder, jforbes, knoel, markmc, scottt.tw, smold, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-12-03 11:54:00 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description igor.redhat@gmail.com 2010-03-22 17:40:42 EDT
Description of problem:

Trying to run m68k debian install ISO under qemu fails. I tried the following two commands:

qemu  -cdrom ~/Junk/debian/68K/debian-etch-m68k-m68k-netinst.iso -hda ~/.qemu-launcher/68k-debian.img  -m 512 -boot d -net nic

This results in the BIOS window popping up and then getting stuck with "Boot failed: Could not read from CDROM (Code 0004). No bootable device". See http://img153.imageshack.us/img153/2512/screenshotqemu.png.

and the following command:

qemu-system-m68k  -cdrom ~/Junk/debian/68K/debian-etch-m68k-m68k-netinst.iso -hda ~/.qemu-launcher/68k-debian.img  -m 512 -boot d -net nic

results in "Kernel image must be specified" - it doesn't even get to loading the BIOS.

The debian iso is obtained from http://people.debian.org/~smarenka/d-i/m68k/cds/daily/debian-etch-m68k-m68k-netinst.iso. I'd have gladly tried a Fedora m68k iso but it doesn't seem to exist.

Version-Release number of selected component (if applicable):

I am on x86_64 F12. I tried this with qemu from both the updates and updates-testing ( with identical results.

How reproducible:


Steps to Reproduce:
1. Grab m68k debian netinstall iso from http://people.debian.org/~smarenka/d-i/m68k/cds/daily/debian-etch-m68k-m68k-netinst.iso
2. create am empty disk image with
qemu-img create -f qcow2 ~/.qemu-launcher/68k-debian.img 10GB
3. Try to install it under qemu with either of the following two commands:

qemu  -cdrom ~/Junk/debian/68K/debian-etch-m68k-m68k-netinst.iso -hda ~/.qemu-launcher/68k-debian.img  -m 512 -boot d -net nic


qemu-system-m68k  -cdrom ~/Junk/debian/68K/debian-etch-m68k-m68k-netinst.iso -hda ~/.qemu-launcher/68k-debian.img  -m 512 -boot d -net nic

Actual results:

Installation fails with an error message

Expected results:

Installation proceeds, m68k Linux gets installed and can be run under qemu.

Additional info:

Please let me know if there is any additional information I can provide.
Comment 1 steve mold 2010-09-28 17:39:33 EDT

Did you resolve this ?

Comment 2 Bug Zapper 2010-11-03 14:52:46 EDT
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 3 Bug Zapper 2010-12-03 11:54:00 EST
Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.