Bug 578507

Summary: SELinux is preventing /bin/mailx access to a leaked inotify file descriptor.
Product: [Fedora] Fedora Reporter: ssabchew <ssabcew>
Component: abrtAssignee: Jiri Moskovcak <jmoskovc>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 12CC: anton, dfediuck, dvlasenk, dwalsh, iprikryl, jmoskovc, kklic, mgrepl, mnowak, npajkovs, ssabcew
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard: setroubleshoot_trace_hash:804cc400e0c457d889634d3d38f4b7ad675d8edb66ff5e784ebaf0648fb08f6e
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-05-05 12:27:52 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description ssabchew 2010-03-31 13:53:39 UTC
Summary:

SELinux is preventing /bin/mailx access to a leaked inotify file descriptor.

Detailed Description:

[mailx has a permissive type (sendmail_t). This access was not denied.]

SELinux denied access requested by the mailx command. It looks like this is
either a leaked descriptor or mailx output was redirected to a file it is not
allowed to access. Leaks usually can be ignored since SELinux is just closing
the leak and reporting the error. The application does not use the descriptor,
so it will run properly. If this is a redirection, you will not get output in
the inotify. You should generate a bugzilla on selinux-policy, and it will get
routed to the appropriate package. You can safely ignore this avc.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385)

Additional Information:

Source Context                system_u:system_r:sendmail_t:s0-s0:c0.c1023
Target Context                system_u:object_r:inotifyfs_t:s0
Target Objects                inotify [ dir ]
Source                        mailx
Source Path                   /bin/mailx
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           mailx-12.4-3.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-99.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   leaks
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.32.9-70.fc12.x86_64 #1 SMP Wed Mar 3 04:40:41
                              UTC 2010 x86_64 x86_64
Alert Count                   2
First Seen                    Wed 31 Mar 2010 04:36:15 PM EEST
Last Seen                     Wed 31 Mar 2010 04:36:15 PM EEST
Local ID                      0144704f-3a0b-44ba-bf88-f6de1eb768a4
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1270042575.814:111667): avc:  denied  { read } for  pid=10637 comm="mailx" path="inotify" dev=inotifyfs ino=1 scontext=system_u:system_r:sendmail_t:s0-s0:c0.c1023 tcontext=system_u:object_r:inotifyfs_t:s0 tclass=dir

node=(removed) type=AVC msg=audit(1270042575.814:111667): avc:  denied  { write } for  pid=10637 comm="mailx" path="/var/run/abrt.lock" dev=dm-1 ino=520 scontext=system_u:system_r:sendmail_t:s0-s0:c0.c1023 tcontext=system_u:object_r:abrt_var_run_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1270042575.814:111667): arch=c000003e syscall=59 success=yes exit=0 a0=1343130 a1=13434a0 a2=7fffe08ab698 a3=7fffe08aaf20 items=0 ppid=8210 pid=10637 auid=4294967295 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=4294967295 comm="mailx" exe="/bin/mailx" subj=system_u:system_r:sendmail_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  leaks,mailx,sendmail_t,inotifyfs_t,dir,read
audit2allow suggests:

#============= sendmail_t ==============
allow sendmail_t abrt_var_run_t:file write;
allow sendmail_t inotifyfs_t:dir read;

Comment 1 Daniel Walsh 2010-03-31 14:38:34 UTC
Looks like abrt is leaking.

Comment 2 Nikola Pajkovsky 2010-05-05 12:27:52 UTC

*** This bug has been marked as a duplicate of bug 518998 ***