Bug 581140

Summary: dvb-usb: did not find the firmware file for DVB-T stick (Terratec Cinergy T3)
Product: [Fedora] Fedora Reporter: Joachim Katzer <jokatzer>
Component: udevAssignee: Harald Hoyer <harald>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 12CC: harald, jonathan
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-04-10 15:47:29 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Joachim Katzer 2010-04-10 08:53:33 EDT
Description of problem:

After updating to udev-145-19, system cannot upload firmware to the DVB-T stick Terratec Cinergy T3. All TV applications are no more working therefore.
In F12 the stick is or was supported by kernel module dvb_usb_dib0700, but needs an additional firmware file which has been copied to /lib/firmware/dvb-usb-dib0700-1.20.fw


Version-Release number of selected component (if applicable):
udev-145-19.fc12.i686
kernel-2.6.32.11-99.fc12.i686 (same problem with 2.6.32.10 and 2.6.32-9.70/67)

How reproducible:
Always

Steps to Reproduce:
1. Plug-in a DVB stick requiring a firmware upload
2. Check /var/log/messages or dmesg
3.
  
Actual results:
F12 reports a "udev firmware loader misses sysfs directory" error. TV not working


Expected results:
F12 should detect DVB-T stick and connect to it as it has worked before update to udev-145-19.

Additional info:
These are the corresponding syslog messages:

Apr 10 14:14:04 localhost kernel: usb 1-1: new high speed USB device using ehci_hcd and address 14
Apr 10 14:14:05 localhost kernel: usb 1-1: New USB device found, idVendor=0ccd, idProduct=10a0
Apr 10 14:14:05 localhost kernel: usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Apr 10 14:14:05 localhost kernel: usb 1-1: Product: TerraTec T3
Apr 10 14:14:05 localhost kernel: usb 1-1: Manufacturer: TerraTec GmbH
Apr 10 14:14:05 localhost kernel: usb 1-1: SerialNumber: 0000000001
Apr 10 14:14:05 localhost kernel: usb 1-1: configuration #1 chosen from 1 choice
Apr 10 14:14:05 localhost kernel: dvb-usb: found a 'Terratec Cinergy T USB XXS (HD)/ T3' in cold state, will try to load a firmware
Apr 10 14:14:05 localhost kernel: usb 1-1: firmware: requesting dvb-usb-dib0700-1.20.fw
Apr 10 14:15:05 localhost kernel: dvb-usb: did not find the firmware file. (dvb-usb-dib0700-1.20.fw) Please see linux/Documentation/dvb/ for more details on firmware-problems. (-2)
Apr 10 14:15:05 localhost firmware.sh[3861]: missing directory /sys/devices/pci0000:00/0000:00:1d.7/usb1/1-1/firmware/1-1/loading
Apr 10 14:15:05 localhost firmware.sh[3861]: udev firmware loader misses sysfs directory

In /sys/devices/pci0000:00/0000:00:1d.7/usb1/1-1 the directory firmware is missing. (Note: I've added a line 'err "missing directory /sys$DEVPATH/loading"' to script /lib/udev/firmware.sh)

Hardware: MacBook2,1
Comment 1 Joachim Katzer 2010-04-10 15:47:29 EDT
Problem was not a bug in udev (or ibus) but apparently be caused by an error in another manually defined udev rule:

file /etc/udev/rules.d/15-huawei-e161.rules:
SUBSYSTEM=="usb", 
SYSFS{idProduct}=="1446", 
SYSFS{idVendor}=="12d1", 
RUN+="/lib/udev/modem-modeswitch --vendor 0x12d1 --product 0x1446 --type option-zerocd"