Bug 582390

Summary: resume results in black but back-lit screen
Product: [Fedora] Fedora Reporter: Sjoerd Mullender <sjoerd>
Component: xorg-x11-drv-nouveauAssignee: Ben Skeggs <bskeggs>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 13CC: airlied, ajax, bskeggs
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-06-27 11:34:34 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
dmesg output right after booting and logging in
none
dmesg output after resume none

Description Sjoerd Mullender 2010-04-14 15:41:56 EDT
Description of problem:
Suspend works fine, but resume results in an unusable system where the screen is completely black with back light on.  Attempting to switch to another virtual terminal has no noticeable effect.

Suspend/resume has never worked for me in the Fedora 11 and Fedora 12 time frame using the nouveau driver.  When I was using F11, I was able to use the nv driver which allowed me to suspend and resume fine.  With F12 I am unfortunately forced to use the proprietary nVidia driver which does allow me to suspend and resume.

My hardware (see http://www.smolts.org/client/show/pub_a8b134cd-bffb-4414-802c-f12fd3cc3b81) is a Dell Inspiron 1720 with a nVidia GeForce 8600M GT (rev a1) graphics card.

Luckily I'm able to login with ssh to the system after a resume (so I was able to get dmesg output), but rebooting didn't work.  I have to hold the power button to force the system off.

Version-Release number of selected component (if applicable):
xorg-x11-drv-nouveau-0.0.15-21.20091105gite1c2efd.fc12.x86_64
kernel-2.6.32.11-99.fc12.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Boot system to runlevel 5, making sure the nouveau driver is used
2.Log in
3.Suspend
4.Resume
  
Actual results:
Black screen

Expected results:
Usable screen

Additional info:
I'll add dmesg output right after a boot and right after a resume.
Comment 1 Sjoerd Mullender 2010-04-14 15:43:01 EDT
Created attachment 406613 [details]
dmesg output right after booting and logging in
Comment 2 Sjoerd Mullender 2010-04-14 15:43:46 EDT
Created attachment 406614 [details]
dmesg output after resume
Comment 3 Sjoerd Mullender 2010-06-17 14:46:25 EDT
On Fedora 13, the problem is almost the same.  I don't get backlight, but I can still login remotely.  Rebooting also doesn't seem to work.

I'm now using kernel-2.6.33.5-124.fc13.x86_64 and xorg-x11-drv-nouveau-0.0.16-6.20100423git13c1043.fc13.x86_64.
Comment 4 Ben Skeggs 2010-06-25 21:05:10 EDT
Can you give the kernel at http://koji.fedoraproject.org/koji/buildinfo?buildID=179667 a try and see if there's any improvement.  If not, fresh dmesg logs would be great!
Comment 5 Sjoerd Mullender 2010-06-26 05:32:59 EDT
For the first time ever I've seen a successful resume when using the nouveau driver.  So it seems this kernel works!
Caveat: I've only tried it once so far.

I did notice that the screen was at its dimmest setting, but that was easily resolved by increasing the brightness.  I have also seen this recently after resuming with the nVidia driver which I have now removed from my system.
Comment 6 Ben Skeggs 2010-06-27 18:32:06 EDT
Excellent!

The backlight coming back dim is probably the fault of the ACPI backlight driver, nouveau doesn't touch it at all, save whatever defaults your VBIOS scripts setup (in all cases I've seen, max brightness).
Comment 7 Sjoerd Mullender 2010-06-28 02:32:35 EDT
I've now suspended and resumed quite a few times, and it all seems to work.  I also didn't have a problem with a dim screen anymore.

I'm happy.  Thanks.
Comment 8 Bug Zapper 2011-06-02 11:22:34 EDT
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Bug Zapper 2011-06-27 11:34:34 EDT
Fedora 13 changed to end-of-life (EOL) status on 2011-06-25. Fedora 13 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.