Bug 582869

Summary: Novatel MC760 USB Broadband modem identified as CD first and not as modem
Product: [Fedora] Fedora Reporter: Robert Lightfoot <BobLfoot>
Component: udevAssignee: Harald Hoyer <harald>
Status: CLOSED WORKSFORME QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: 13CC: dcbw, harald, jonathan, nerijus
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-04-25 17:05:15 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
outputs of lsusb and mount at various stages of process none

Description Robert Lightfoot 2010-04-15 22:30:39 EDT
Created attachment 406974 [details]
outputs of lsusb and mount at various stages of process

Description of problem: When plugged in the Novatel MC760 USB modem for VirginMobile is identified as /dev/sr1 rather than /dev/ttyUSB0 


Version-Release number of selected component (if applicable):
Seen in Fedora 12 and Fedora 13 Beta RC5

How reproducible:
Plug in modem and wait for udev - automount to cycle

Steps to Reproduce:
1. Insert MC760 USB modem and wait
2.
3.
  
Actual results:
MC760 USB Modem mounted as /dev/sr1 on /media/Broadband2Go
from GNOME Desktop mounted CD had to be ejected
Then MC760 USB was seen as a Broadband Modem

Expected results:
After plugin Network Manager should have presented with Mobile Broadband option.

Additional info:
Attaching lsusb and mount output at different steps
001 - lsusb when first inserted
002 - mount when first inserted
003 - lsusb after ejecting CD
004 - mount after ejecting CD
Comment 1 Harald Hoyer 2010-04-16 02:00:45 EDT
you want to use usb_modeswitch to turn the modem in modem mode.
Comment 2 Robert Lightfoot 2010-04-16 06:10:23 EDT
Harold - I have never heard of usb_modeswitch before can you elaborate or post a url to what you refer.  Bob
Comment 3 Harald Hoyer 2010-04-16 11:33:30 EDT
 yum info usb_modeswitch
[sudo] password for harald: 
Loaded plugins: presto, refresh-packagekit
Installed Packages
Name       : usb_modeswitch
Arch       : x86_64
Version    : 1.0.5
Release    : 1.fc12
Size       : 87 k
Repo       : installed
From repo  : fedora
Summary    : USB Modeswitch gets 4G cards in operational mode
URL        : http://www.draisberghof.de/usb_modeswitch/
License    : GPLv2+
Description: USB Modeswitch brings up your datacard into operational mode. When plugged
           : in they identify themselves as cdrom and present some non-Linux compatible
           : installation files. This tool deactivates this cdrom-devices and enables
           : the real communication device. It supports most devices built and
           : sold by Huawei, T-Mobile, Vodafone, Option, ZTE, Novatel.
Comment 4 Harald Hoyer 2010-04-16 11:33:51 EDT
hmm, I wonder where it went in F13
Comment 5 Harald Hoyer 2010-04-16 11:36:10 EDT
(In reply to comment #4)
> hmm, I wonder where it went in F13    

ah.. not updated since F12..
Comment 6 Robert Lightfoot 2010-04-16 21:43:31 EDT
F12 successful operation using CLI command --

usb_modeswitch -v 0x1410 -p 0x5031 -V 0x1410 -P 0x6002 \
-M "5553424312345678000000000000061b000000020000000000000000000000"

yum install usb_modeswitch did not generate or deliver a /lib/udev/rules.d/40-usb_modeswitch.rules file.  

Still trying to sort out proper format for udev rules file to automate this process.
Comment 7 Robert Lightfoot 2010-04-16 23:30:01 EDT
F13 successful CLI both from the Fedora Default Package and from the http://www.draisberghof.de/usb_modeswitch/ source made on F13 system.

Could not get an automated plug in and switch to work.  Had to execute usb_modeswitch command from CLI in every attempted instance.
Comment 8 Nerijus Baliƫnas 2010-04-18 18:05:33 EDT
Automated usb_modeswitch does not work for me too.
I have ZTE MF628 modem. I uncommented the following lines in /etc/usb_modeswitch.conf:

DefaultVendor=  0x19d2
DefaultProduct= 0x2000

TargetVendor=   0x19d2
TargetProduct=  0x0015

MessageContent="5553424312345678000000000000061b000000030000000000000000000000"

I created /etc/udev/rules.d/z99-omniconnect.rules:

SUBSYSTEM=="usb", ATTRS{idVendor}=="19d2", ATTRS{idProduct}=="2000", RUN+="/usr/bin/usb_modeswitch"

When I connect the modem it does not switch to modem mode:

usb 5-2: new full speed USB device using uhci_hcd and address 2
hub 5-0:1.0: unable to enumerate USB device on port 2
usb 5-2: new full speed USB device using uhci_hcd and address 3
usb 5-2: New USB device found, idVendor=19d2, idProduct=2000
usb 5-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 5-2: Product: USB ZTE Storage
usb 5-2: Manufacturer: Qualcomm, Incorporated
usb 5-2: usbfs: process 1957 (usb_modeswitch) did not claim interface 0 before use
btusb_intr_complete: hci0 urb e17e8e70 failed to resubmit (1)
btusb_bulk_complete: hci0 urb e17e8000 failed to resubmit (1)
btusb_bulk_complete: hci0 urb e17e8790 failed to resubmit (1)
usb 5-2: usbfs: process 1963 (usb_modeswitch) did not claim interface 0 before use
usb 5-2: USB disconnect, address 3

Then I remove /etc/udev/rules.d/z99-omniconnect.rules and reconnect the modem again:

usb 5-2: new full speed USB device using uhci_hcd and address 4
hub 5-0:1.0: unable to enumerate USB device on port 2
usb 5-2: new full speed USB device using uhci_hcd and address 5
usb 5-2: New USB device found, idVendor=19d2, idProduct=2000
usb 5-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 5-2: Product: USB ZTE Storage
usb 5-2: Manufacturer: Qualcomm, Incorporated
scsi3 : usb-storage 5-2:1.0
btusb_intr_complete: hci0 urb e15f42c0 failed to resubmit (1)
btusb_bulk_complete: hci0 urb e15f4e70 failed to resubmit (1)
btusb_bulk_complete: hci0 urb e15f4000 failed to resubmit (1)
scsi 3:0:0:0: CD-ROM            ZTE Corp USB Storage      2.31 PQ: 0 ANSI: 2
sr1: scsi-1 drive
sr 3:0:0:0: Attached scsi generic sg2 type 5

Then I run usb_modeswitch manually:

usb 5-2: usbfs: process 1984 (usb_modeswitch) did not claim interface 0 before use
btusb_intr_complete: hci0 urb e7b409a0 failed to resubmit (1)
btusb_bulk_complete: hci0 urb e7b40580 failed to resubmit (1)
btusb_bulk_complete: hci0 urb e7b408f0 failed to resubmit (1)
usb 5-2: USB disconnect, address 5
usb 5-2: new full speed USB device using uhci_hcd and address 6
hub 5-0:1.0: unable to enumerate USB device on port 2
usb 5-2: new full speed USB device using uhci_hcd and address 7
usb 5-2: New USB device found, idVendor=19d2, idProduct=0015
usb 5-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 5-2: Product: ZTE CDMA Technologies MSM
usb 5-2: Manufacturer: Qualcomm, Incorporated
usb 5-2: SerialNumber: Data Interface
scsi4 : usb-storage 5-2:1.0
usbcore: registered new interface driver usbserial
USB Serial support registered for generic
usbcore: registered new interface driver usbserial_generic
usbserial: USB Serial Driver core
USB Serial support registered for GSM modem (1-port)
option 5-2:1.1: GSM modem (1-port) converter detected
usb 5-2: GSM modem (1-port) converter now attached to ttyUSB0
option 5-2:1.2: GSM modem (1-port) converter detected
usb 5-2: GSM modem (1-port) converter now attached to ttyUSB1
option 5-2:1.3: GSM modem (1-port) converter detected
usb 5-2: GSM modem (1-port) converter now attached to ttyUSB2
usbcore: registered new interface driver option
option: v0.7.2:USB Driver for GSM modems

And now it works.
Comment 9 Nerijus Baliƫnas 2010-04-24 19:33:09 EDT
With usb_modeswitch-1.1.2-3.fc13 I don't need to create /etc/udev/rules.d/z99-omniconnect.rules and everything works automatically, i.e. when I plug in modem, usb_modeswitch runs automatically and successfully.
Comment 10 Robert Lightfoot 2010-04-25 17:05:15 EDT
With usb_modeswitch-1.1.2-3.fc13 I don't need to create
/etc/udev/rules.d/ rules and everything works automatically,
i.e. when I plug in modem, usb_modeswitch runs automatically and successfully.