Bug 583004

Summary: Couchdb initscript can't start couchdb
Product: [Fedora] Fedora Reporter: Jeff Weiss <jweiss>
Component: couchdbAssignee: Peter Lemenkov <lemenkov>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 13CC: dajohnso, lemenkov, thingie
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: couchdb-0.10.2-3.el5 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-05-18 21:48:20 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Jeff Weiss 2010-04-16 12:16:06 UTC
Description of problem:
[root@hiredgoons couchdb]# service couchdb start
Starting couchdb: Apache CouchDB needs write permission on the STDOUT file: couchdb.stdout
                                                           [FAILED]


Version-Release number of selected component (if applicable):
[root@hiredgoons couchdb]# rpm -q couchdb
couchdb-0.10.0-2.fc13.i686


How reproducible:
always, for me

Steps to Reproduce:
1. yum install couchdb
2. service couchdb start
3.
  
Actual results:
Above error

Expected results:
Couchdb starts normally

Additional info:
I tried looking at /etc/sysconfig/couchdb.
COUCHDB_STDOUT_FILE=/dev/null
COUCHDB_STDERR_FILE=/dev/null

couchdb user has write perms to /dev/null.
I tried editing this file to read

COUCHDB_STDOUT_FILE=/var/lib/couchdb/couchdb.stdout
COUCHDB_STDERR_FILE=/var/lib/couchdb/couchdb.stderr

and I created those files owned by couchdb, it had no effect.

However starting couchdb by

[root@hiredgoons couchdb]# su - couchdb 
-bash-4.1$ couchdb -b
Apache CouchDB has started, time to relax.
-bash-4.1$

works fine.

Comment 1 Honza 'thingie' Bartoš 2010-05-11 09:31:49 UTC
I have no idea why, but I tried to strace init scripts, and it tries to access couchdb.stdout and couchdb.stderr directly in /. No matter how I set those vars in /etc/sysconfig/couchdb. If I create those files in / and make them writable for couchdb, it works (well, that's very crappy workaround).

Comment 2 Peter Lemenkov 2010-05-12 13:44:37 UTC
Folks, could you, please, test whether issue is still exists with the latest  couchdb package (couchdb-0.10.2).

I can't reproduce this bug with freshly installed couchdb.

[root@Sulaco ~]# service couchdb start
Запускается couchdb: Apache CouchDB has started, time to relax.
                                                           [  OK  ]
[root@Sulaco ~]#

Comment 3 Honza 'thingie' Bartoš 2010-05-12 14:13:23 UTC
[root@morana ~]# rpm -q couchdb #newest version downloaded from koji
couchdb-0.10.2-1.fc13.i686
[root@morana ~]# service couchdb start
Starting couchdb: Apache CouchDB needs write permission on the STDOUT file: couchdb.stdout
                                                           [FAILED]

Looks like nothing has changed.

Comment 4 Peter Lemenkov 2010-05-13 10:55:21 UTC
Folks, please try these builds:

* F-12: http://koji.fedoraproject.org/koji/taskinfo?taskID=2184941
* F-13: http://koji.fedoraproject.org/koji/taskinfo?taskID=2184947

Please, note that couchdb uses values from /etc/sysconfig/couchdb since this build (it didn't use them previously), so if you added something here during your attempts to fix this issue, then you're should take care of it - I suggest you to reset them to default values:

COUCHDB_USER=couchdb
COUCHDB_STDOUT_FILE=/dev/null
COUCHDB_STDERR_FILE=/dev/null
COUCHDB_RESPAWN_TIMEOUT=0
COUCHDB_OPTIONS=

Comment 5 Honza 'thingie' Bartoš 2010-05-13 11:12:26 UTC
couchdb-0.10.2-3.fc13 seems to fix this issue (or at least it works for me).

Comment 6 Jeff Weiss 2010-05-13 12:04:46 UTC
This is working for me now with the package Peter linked to for F13.

Comment 7 Peter Lemenkov 2010-05-13 12:09:06 UTC
(In reply to comment #5)
> couchdb-0.10.2-3.fc13 seems to fix this issue (or at least it works for me).    

(In reply to comment #6)
> This is working for me now with the package Peter linked to for F13.    

Great news! So I'm building this package right now and will push it into repositories very soon.

Comment 8 Fedora Update System 2010-05-13 12:43:04 UTC
couchdb-0.10.2-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/couchdb-0.10.2-3.fc11

Comment 9 Fedora Update System 2010-05-13 12:43:09 UTC
couchdb-0.10.2-3.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/couchdb-0.10.2-3.el5

Comment 10 Fedora Update System 2010-05-13 12:43:13 UTC
couchdb-0.10.2-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/couchdb-0.10.2-3.fc13

Comment 11 Fedora Update System 2010-05-13 12:43:17 UTC
couchdb-0.10.2-3.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/couchdb-0.10.2-3.fc12

Comment 12 Fedora Update System 2010-05-13 19:24:58 UTC
couchdb-0.10.2-3.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update couchdb'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/couchdb-0.10.2-3.fc13

Comment 13 Fedora Update System 2010-05-13 19:25:55 UTC
couchdb-0.10.2-3.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update couchdb'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/couchdb-0.10.2-3.fc11

Comment 14 Fedora Update System 2010-05-13 19:34:12 UTC
couchdb-0.10.2-3.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update couchdb'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/couchdb-0.10.2-3.fc12

Comment 15 Fedora Update System 2010-05-14 01:04:56 UTC
couchdb-0.10.2-3.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update couchdb'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/couchdb-0.10.2-3.el5

Comment 16 Fedora Update System 2010-05-18 21:48:16 UTC
couchdb-0.10.2-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2010-05-18 21:56:12 UTC
couchdb-0.10.2-3.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2010-05-18 22:00:04 UTC
couchdb-0.10.2-3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2010-05-29 00:18:57 UTC
couchdb-0.10.2-3.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.