Bug 585926

Summary: "kernel BUG at mm/slab.c:2974!"
Product: Red Hat Enterprise Linux 6 Reporter: Jay Turner <jturner>
Component: kernelAssignee: Larry Woodman <lwoodman>
Status: CLOSED WORKSFORME QA Contact: Red Hat Kernel QE team <kernel-qe>
Severity: medium Docs Contact:
Priority: high    
Version: 6.0CC: codezilla, pj, qbarnes, qcai, srevivo
Target Milestone: rc   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-08-05 05:28:09 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Comment 2 RHEL Program Management 2010-04-26 14:13:56 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 RHEL Program Management 2010-07-15 15:06:04 UTC
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **

Comment 4 Qian Cai 2010-07-20 00:55:46 UTC
*** Bug 594604 has been marked as a duplicate of this bug. ***

Comment 5 Qian Cai 2010-07-20 15:28:22 UTC
Description of problem:
Had a machine running 2.6.32-20.el6.x86_64 which had been sitting idle for 6
days.  Came in Monday morning and started poking around on the web and the
kernel panic'd.  Sadly I didn't have kdump configured for compression, so the
dump is 5.9G, but I'll post it for anyone interested.

Crash output:

      KERNEL: /usr/lib/debug/lib/modules/2.6.32-20.el6.x86_64/vmlinux
    DUMPFILE: vmcore
        CPUS: 12
        DATE: Mon Apr 26 06:05:00 2010
      UPTIME: 9 days, 23:04:27
LOAD AVERAGE: 0.06, 0.41, 0.25
       TASKS: 499
    NODENAME: cobalt.devel.redhat.com
     RELEASE: 2.6.32-20.el6.x86_64
     VERSION: #1 SMP Tue Apr 6 13:40:08 EDT 2010
     MACHINE: x86_64  (3333 Mhz)
      MEMORY: 6 GB
       PANIC: "kernel BUG at mm/slab.c:2974!"
         PID: 24191
     COMMAND: "ksmtuned"
        TASK: ffff8801a47e4ac0  [THREAD_INFO: ffff88017c5a6000]
         CPU: 9
       STATE: TASK_RUNNING (PANIC)

Version-Release number of selected component (if applicable):
2.6.32-20.el6

How reproducible:
Has happened only once and I've been using this machine pretty regularly. 
Granted this is the longest that the machine has sat idle.

Comment 7 Larry Woodman 2010-07-20 20:13:10 UTC
There has not been a BUG in mm/slab.c since 2.6.32-23 which was built on April 27 2010.  We are currently up to 2.6.32-51 and there have been hundreds of commits since that time.  I have not been able to reproduce this problem at all.  Can someone who has seen this problem before try to reproduce it in a more recent kernel and it its possible get a crashdump?  I know the BUG from the -23 kernel indicated that the slab was either free or on the partial list so there should have been at least one free object and there wasnt any.  Any help reproducing this problem with a recent kernel would be necessary to figure out if this problem still exists and the dump necessary to fix it.

Larry Woodman